1

When trying to update system, I encounter a peculiar issue where yay identifies that a nodejs-lts-gallium would need to be upgraded, through direct? or indirect (most likely) depdency:

$ yay -Syu
(...)
 -> No AUR package found for nodejs-lts-gallium
(...)
 -> could not find all required packages: nodejs-lts-gallium

It seems that this package has been removed from aur. I'm not able to find out how to get away from this message, as I don't seem to find which package is dependent upon this package:

$ pacman -Q | grep nodejs

And looking in paclog about this package, I find that it was removed:

paclog --package=nodejs-lts-gallium
[2022-03-23T20:14:55-0400] [ALPM] installed nodejs-lts-gallium (16.14.2-1)
[2022-04-21T09:48:30-0400] [ALPM] upgraded nodejs-lts-gallium (16.14.2-1 -> 16.14.2-2)
[2022-04-29T17:01:11-0400] [ALPM] upgraded nodejs-lts-gallium (16.14.2-2 -> 16.15.0-1)
[2022-06-08T00:04:32-0400] [ALPM] upgraded nodejs-lts-gallium (16.15.0-1 -> 16.15.1-1)
[2022-07-12T16:17:11-0400] [ALPM] upgraded nodejs-lts-gallium (16.15.1-1 -> 16.16.0-1)
[2022-10-23T14:10:19-0400] [ALPM] upgraded nodejs-lts-gallium (16.16.0-1 -> 16.16.0-2)
[2022-11-13T21:42:27-0500] [ALPM] upgraded nodejs-lts-gallium (16.16.0-2 -> 16.18.0-1)
[2022-12-29T21:56:27-0500] [ALPM] upgraded nodejs-lts-gallium (16.18.0-1 -> 16.19.0-1)
[2023-03-01T09:45:37-0500] [ALPM] upgraded nodejs-lts-gallium (16.19.0-1 -> 16.19.1-1)
[2023-04-01T15:22:45-0400] [ALPM] upgraded nodejs-lts-gallium (16.19.1-1 -> 16.20.0-1)
[2023-05-16T19:05:15-0400] [ALPM] removed nodejs-lts-gallium (16.20.0-1)

My question is:

  • What is yay looking for when it receives -> No AUR package found for nodejs-lts-gallium ? Is there a command to get exactly that information ?
  • How can this error be resolved ?

Full log of yay:

$ yay -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
:: Searching AUR for updates...
 -> No AUR package found for nodejs-lts-gallium
:: Searching databases for updates...
:: 9 dependencies will also be installed for this operation.
   extra/doxygen            -> 1.10.0-3
   (make dependency of alsaplayer)
   extra/gendesk            -> 1.0.9-3
   (make dependency of dropbox)
   extra/lhasa              -> 0.3.1-3
   (make dependency of wd719x-firmware)
   extra/libmikmod          -> 3.3.11.1-6
   (make dependency of alsaplayer)
   extra/npm                -> 10.5.2-1
   (make dependency of lens)
   extra/python-build       -> 1.2.1-1
   (make dependency of python-nvidia-ml-py)
   extra/python-installer   -> 0.7.0-4
   (make dependency of python-nvidia-ml-py)
   extra/sassc              -> 3.6.2-4
   (make dependency of adw-gtk3)
   aur/python-pynvml        -> 11.5.0-1

:: 22 packages to upgrade/install.
22  extra/docker-buildx                     0.13.1-1       -> 0.14.0-1
21  extra/libmpeg2                          0.5.1-8        -> 0.5.1-9
20  aur/adw-gtk3                            5.0-1          -> 5.3-2
19  aur/aic94xx-firmware                    30-9           -> 30-10
18  aur/alsaplayer                          0.99.81-9      -> 0.99.81-10
17  aur/brave-bin                           1:1.61.109-1   -> 1:1.65.114-1
16  aur/dropbox                             40.4.46-1      -> 191.4.4995-1
15  aur/goland                              2023.3.2-1     -> 2024.1-1
14  aur/google-chrome                       73.0.3683.86-1 -> 124.0.6367.60-1
13  aur/lazydocker                          0.17.1-1       -> 0.23.1-1
12  aur/lens                                3.6.7-1        -> 6.5.2-1
11  aur/nvitop                              1.3.1-1        -> 1.3.2-1
10  aur/pacdep                              1.1.0-3        -> 1.1.0-4
 9  aur/pacgraph                            20110629-6     -> 20110629-8
 8  aur/prince-bin                          15.1-1         -> 15.3-1
 7  aur/publii                              0.34.1-1       -> 0.45.2-1
 6  aur/python-nvidia-ml-py                 12.535.108-1   -> 12.535.133-2
 5  aur/qdirstat                            1.6.1-1        -> 1.9-2
 4  aur/rclone-browser                      1.2-1          -> 1.8.0-3
 3  aur/sweethome3d-3dmodels-blendswap-cc0  1.8-1          -> 1.9.1-2
 2  aur/synology-drive                      3.0.1_12667-1  -> 3.4.0_15724-1
 1  aur/wd719x-firmware                     1-3            -> 1-7
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
==> 
 -> could not find all required packages: nodejs-lts-gallium
1
  • no need for yay -Syu yay just does that for you Commented Apr 20 at 3:33

2 Answers 2

1

I think I found it. The key was to run yay with --debug.

I personally modified: ~/.config/yay/config.json with:

{
  "debug": true
}

Running with debug, I got:

$ yay -Syu        
[DEBUG:runner] running /usr/bin/sudo pacman -S -y --config /etc/pacman.conf --
:: Synchronizing package databases...
 core is up to date
 extra is up to date
[DEBUG:db] populating db executor package caches. sync_len 1414 remote_len 25
:: Searching AUR for updates...
[DEBUG:runtime] packages to query [adw-gtk-theme adw-gtk3 aic94xx-firmware alsaplayer ast-fw aws-sam-cli-bin brave-bin dropbox fetchmirrors goland google-chrome lens nvm pacdep pacgraph prince-bin qdirstat qscan rclone-browser spotify-tui sweethome3d-3dmodels-blendswap-cc0 synology-drive vcal wd719x-firmware yay]
[DEBUG:runtime] rpc request https://aur.archlinux.org/rpc?arg%5B%5D=adw-gtk-theme&arg%5B%5D=adw-gtk3&arg%5B%5D=aic94xx-firmware&arg%5B%5D=alsaplayer&arg%5B%5D=ast-fw&arg%5B%5D=aws-sam-cli-bin&arg%5B%5D=brave-bin&arg%5B%5D=dropbox&arg%5B%5D=fetchmirrors&arg%5B%5D=goland&arg%5B%5D=google-chrome&arg%5B%5D=lens&arg%5B%5D=nvm&arg%5B%5D=pacdep&arg%5B%5D=pacgraph&arg%5B%5D=prince-bin&arg%5B%5D=qdirstat&arg%5B%5D=qscan&arg%5B%5D=rclone-browser&arg%5B%5D=spotify-tui&arg%5B%5D=sweethome3d-3dmodels-blendswap-cc0&arg%5B%5D=synology-drive&arg%5B%5D=vcal&arg%5B%5D=wd719x-firmware&arg%5B%5D=yay&type=info&v=5
[DEBUG:grapher] brave-bin provides: brave
[DEBUG:grapher] brave-bin provides: brave-browser
[DEBUG:grapher] prince-bin provides: prince
[DEBUG:grapher] prince-bin provides: princexml
[DEBUG:grapher] deps to find [nodejs-lts-gallium]
[DEBUG:runtime] packages to query [nodejs-lts-gallium]
[DEBUG:runtime] rpc request https://aur.archlinux.org/rpc?arg%5B%5D=nodejs-lts-gallium&type=info&v=5
[DEBUG:runtime] rpc request https://aur.archlinux.org/rpc?arg=nodejs-lts-gallium&by=provides&type=search&v=5
 -> No AUR package found for nodejs-lts-gallium

So dependency resolution is done by an rpc-like (but HTTPS GET) call to: https://aur.archlinux.org/rpc?arg%5B%5D=adw-gtk-theme&arg%5B%5D=adw-gtk3&arg%5B%5D=aic94xx-firmware&arg%5B%5D=alsaplayer&arg%5B%5D=ast-fw&arg%5B%5D=aws-sam-cli-bin&arg%5B%5D=brave-bin&arg%5B%5D=dropbox&arg%5B%5D=fetchmirrors&arg%5B%5D=goland&arg%5B%5D=google-chrome&arg%5B%5D=lens&arg%5B%5D=nvm&arg%5B%5D=pacdep&arg%5B%5D=pacgraph&arg%5B%5D=prince-bin&arg%5B%5D=qdirstat&arg%5B%5D=qscan&arg%5B%5D=rclone-browser&arg%5B%5D=spotify-tui&arg%5B%5D=sweethome3d-3dmodels-blendswap-cc0&arg%5B%5D=synology-drive&arg%5B%5D=vcal&arg%5B%5D=wd719x-firmware&arg%5B%5D=yay&type=info&v=5

Analyzing this response payload, I see:

{
    "Conflicts": [
        "lens-bin"
    ],
    "Depends": [
        "gtk3",
        "libxss",
        "nss"
    ],
    "Description": "The Kubernetes IDE",
    "FirstSubmitted": 1585291446,
    "ID": 1275472,
    "Keywords": [
        "aks",
        "dashboard",
        "devops",
        "kubernetes"
    ],
    "LastModified": 1687165784,
    "License": [
        "MIT"
    ],
    "Maintainer": "ogarcia",
    "MakeDepends": [
        "npm",
        "nodejs-lts-gallium"
    ],
    "Name": "lens",
    "NumVotes": 8,
    "OptDepends": [
        "kubectl",
        "helm"
    ],
    "OutOfDate": null,
    "PackageBase": "lens",
    "PackageBaseID": 150750,
    "Popularity": 0.043536,
    "Submitter": "dbirks",
    "URL": "https://k8slens.dev",
    "URLPath": "/cgit/aur.git/snapshot/lens.tar.gz",
    "Version": "6.5.2-1"
}

Checking what I have installed, I find that lens is installed.

Removed lens and now everything is back to normal. Thank you!

1

nodejs-lts-gallium is an old lts version of nodejs which has passed its support period and hence it is no longer in the AUR. The latest lts release is nodejs-lts-iron. However there is a nodejs package in the Arch repositories which presumably is a rolling version with the latest updates.

To fix that issue remove nodejs-lts-gallium and replace it with the new lts or rolling version. I chose the rolling version and had to use the --overwrite=* switch for pacman to resolve it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .