I've been trying to get hibernation to work, and am having problems. The system seems to go into hibernation just fine, but when I try to restore from disk, the process stops just after a message saying "Image restoration successful". This is before I'm able to switch to a new tty. Ctrl-alt-del works. SysRq commands seem to work, although I'm not sure what to do with them.

Suspend (to RAM) works fine when I close the lid or use s2ram or pm-suspend. If I use s2both or s2disk, I see the messages about the image being written to disk; if I treat s2both (or pm-suspend-hybrid) as a suspend (eg, restore without cutting power), it works. But if I cut power and do a cold boot, after the progress indicator seems to say the image is done loading, the process just stops.

Does anyone know how I can fix this? Or at least what my next debugging/troubleshooting steps should be?

I'm using (K)Ubuntu 12.04, kernel 3.2.0-38-generic. I have 2GB of RAM and 4GB of swap.

This (month-old unanswered forum post) looks very similar to my situation (except for the message about user id - which he gets but I don't) http://forum.linuxmint.com/viewtopic.php?p=708058&sid=e8bd8eba8fad0b25597209e365d6edf4


Edit: Update

So, this is now kinda 'half-solved'. Gilles' answer got me past the place where I was stuck, but I still don't know what caused the problem. I am now having further problems, so I will need to keep debugging this, in case they are related - and would very much welcome further tips on what might have caused this problem in the first place.

(New problem seems to be a more severe lock-up (that 'magic SysRq' doesn't help) when I try to hibernate/s2disk with more than ~500MB of memory used. Didn't think to test w/ a high memory load, ouch ...)

  • Recently I've seen that waking-up may end up with black screen instead of showing locked X11 screen. It is probably some corner case in the graphic driver, since switching to linux console and back solves the problem. Have you tried that - i.e. switching to linux console and back to X? You may also run sshd onn the machine, connect to it over network and check kernel logs remotely (if the framebuffer console approach failed). – peterph May 29 '13 at 9:54
  • @peterph, My system stops the resume process before I get to that point; what you're calling the "linux console" is what I meant by "tty". IOW, yes I've tried 'ctrl-alt-f1', and it doesn't work. I doubt the system would get far enough to start sshd. I have checked kernel logs after rebooting; so far I haven't found anything useful, but would welcome suggestions on what to look for. Thanks for the suggestions. – hunter2 May 29 '13 at 10:16
  • Also - IIUC, pm-suspend-hybrid calls s2both ... does it do anything else? Is there a reason to use one over the other? (I know this is a different question, but I havent searched for the answer enough to be ready to post it as one - just figured if someone reading this knows the answer offhand ... thanks) – hunter2 May 30 '13 at 5:55
  • You could also try uninstalling pm-utils (to make sure they don't interfere) and trying to do it the old-fashined way: echo -n disk > /sys/power/state - see Documentation/power/ in kernel source tree, especially basic-pm-debugging.txt. – peterph May 30 '13 at 7:43
  • I tried the /sys/power/state way before, with no luck. Good note on the documentation, I'll check that out. Like I said, I'm curious to know the difference/what pm-things do; I think they are designed to run over s2things, and possibly do other things (change ENV, run other scripts, etc) - eg, probably not a conflict there. Do you actually know that pm-utils can conflict with something? B/c I don't want to start uninstalling stuff 'just cuz'. – hunter2 May 31 '13 at 2:52

I've observed the same problem, also on Ubuntu 12.04. After resuming, the system is displaying a text mode console and looks frozen, but magic SysRq responds.

I've found that Alt+SysRq+E (which kills all the programs on the current virtual console) works for me. This doesn't kill any of my programs, it's only killing processes on the temporary console used during hibernation preparation.

I have no explanation, I just found that this worked for me and didn't investigate any further.

Note for laptop users:

  1. Press and hold Alt and Fn.
  2. Press and release SysRq (which may be on Pause or PrintScreen or some other function key depending on your model).
  3. Release Fn (but keep Alt down).
  4. Press and release E.
  5. Release Alt.
  • 1
    Thanks! That (basically) did it for me. K was actually for "SAK", but I used E (terminate all tasks), and .. finished resuming. For me (also on a laptop), it's fn + SysRq, then hold SysRq and release fn (then press 'magic' combos). Tested a couple different ways, including with two monitors active. Giving you the check because this does get me past the problem, but if anyone would care to offer further tips on why this is happening / what's hanging the 'hibernation console', that would be nice. – hunter2 May 30 '13 at 3:26
  • 1
    +1 for the step by step guide for Fn-ed keyboards (which is tricky). :) – peterph May 30 '13 at 7:39
  • I'm having some other problems. Not sure if they're caused by this, but as part of diagnosing, I want to try to figure out the underlying problem here. Have you looked into this any further since posting? (I'm assuming 'no', but figured I'd ask before opening a new question for almost-the-same problem). – hunter2 Jul 2 '13 at 5:00
  • @hunter2 No, I havent' looked any further. The effort/reward ratio is too low for me. – Gilles 'SO- stop being evil' Jul 2 '13 at 7:26
  • Fair 'nough. Thanks for the quick response. – hunter2 Jul 2 '13 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.