0

I'm facing an issue with my MT7601U network adapter on Linux. Although I've successfully entered monitor mode, I'm encountering difficulties capturing handshakes and discovering devices in the network/s. Strangely, only WPS attacks seem to work reliably.

Here are the key details:

  • Adapter: Ralink MT7601U
  • Distribution: parrotOS 6.0 (lorikeet) 64-bit Kernel 6.8.0-xxxxx
  • Problem Summary:
    • Monitor mode is enabled.
    • Unable to capture handshakes or detect devices in the network, except for WPS attacks which is very different kind of wifi attack.
  • Attempts to Resolve:
    • Successfully entered monitor mode using the iw command (sudo iw dev <interface> set monitor control).
    • Tried various tools like Aircrack-ng, Wireshark, and tcpdump for packet capture, but no success in capturing handshakes.
    • Even after ensuring monitor mode is active, no devices are being discovered in the network, except during WPS attacks.
  • Observations:
    • Checked system logs (dmesg, /var/log/syslog) but found no relevant error messages.
    • Updated drivers through the package manager and also tried downloading from the manufacturer's website, but the issue persists.

I'm reaching out to the community for guidance on troubleshooting steps or potential solutions to this problem. Any advice or insights from users familiar with the MT7601U adapter or similar issues with other adapters would be greatly appreciated.

Thank you for your assistance!

1 Answer 1

1

I solved it by running the following commands sudo airmon-ng check kill Before using sudo airmon-ng start <NETWORK INTERFACE>

everything works great and I finally can enjoy my new wifi adapter. Thanks for anyone who was concerned ♥️

If anybody have explanation for it it will be great!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .