0

I installed squid 6.2. I built it from sources with ssl. the service starts normally. there are 2 network cards. one looks at the local network, the other at the Internet. I used the manual for configuring configuration files from the Internet. After executing the sudo squid -k reconfigure and sudo squid -k commands, the output is as follows

  2024/04/09 22:08:41| Processing Configuration File: /etc/squid/squid.conf (depth 0)
2024/04/09 22:08:41| Processing: acl localnet src 0.0.0.1-0.255.255.255 # RFC 1122 "this" network (LAN)
2024/04/09 22:08:41| Processing: acl localnet src 10.0.0.0/8            # RFC 1918 local private network (LAN)
2024/04/09 22:08:41| Processing: acl localnet src 100.64.0.0/10         # RFC 6598 shared address space (CGN)
2024/04/09 22:08:41| Processing: acl localnet src 169.254.0.0/16        # RFC 3927 link-local (directly plugged) machines
2024/04/09 22:08:41| Processing: acl localnet src 172.16.0.0/12         # RFC 1918 local private network (LAN)
2024/04/09 22:08:41| Processing: acl localnet src 192.168.0.0/24               # RFC 1918 local private network (LAN)
2024/04/09 22:08:41| Processing: acl localnet src fc00::/7              # RFC 4193 local private network range
2024/04/09 22:08:41| Processing: acl localnet src fe80::/10             # RFC 4291 link-local (directly plugged) machines
2024/04/09 22:08:41| Processing: acl SSL_ports port 443
2024/04/09 22:08:41| Processing: acl Safe_ports port 80         # http
2024/04/09 22:08:41| Processing: acl Safe_ports port 21         # ftp
2024/04/09 22:08:41| Processing: acl Safe_ports port 443                # https
2024/04/09 22:08:41| Processing: acl Safe_ports port 70         # gopher
2024/04/09 22:08:41| Processing: acl Safe_ports port 210                # wais
2024/04/09 22:08:41| Processing: acl Safe_ports port 1025-65535 # unregistered ports
2024/04/09 22:08:41| Processing: acl Safe_ports port 280                # http-mgmt
2024/04/09 22:08:41| Processing: acl Safe_ports port 488                # gss-http
2024/04/09 22:08:41| Processing: acl Safe_ports port 591                # filemaker
2024/04/09 22:08:41| Processing: acl Safe_ports port 777                # multiling http
2024/04/09 22:08:41| Processing: http_access deny !Safe_ports
2024/04/09 22:08:41| Processing: http_access deny CONNECT !SSL_ports
2024/04/09 22:08:41| Processing: http_access allow localhost manager
2024/04/09 22:08:41| Processing: http_access deny manager
2024/04/09 22:08:41| Processing: include /etc/squid/conf.d/*.conf
2024/04/09 22:08:41| Processing Configuration File: /etc/squid/conf.d/debian.conf (depth 1)
2024/04/09 22:08:41| Processing: logfile_rotate 0
2024/04/09 22:08:41| Processing: http_access allow localhost
2024/04/09 22:08:41| Processing: http_access allow localnet
2024/04/09 22:08:41| Processing: http_access allow all
2024/04/09 22:08:41| Processing: http_port 3130
2024/04/09 22:08:41| Processing: https_port 192.168.0.110:3129 intercept ssl-bump cert=/etc/squid/squidCA.pem generate-host-certificates=on dynamic_cert_mem_cache_size=4MB
2024/04/09 22:08:41| Starting Authentication on port 192.168.0.110:3129
2024/04/09 22:08:41| Disabling Authentication on port 192.168.0.110:3129 (interception enabled)
2024/04/09 22:08:41| Processing: http_port 192.168.0.110:3128 intercept
2024/04/09 22:08:41| Starting Authentication on port 192.168.0.110:3128
2024/04/09 22:08:41| Disabling Authentication on port 192.168.0.110:3128 (interception enabled)
2024/04/09 22:08:41| Processing: sslcrtd_program /usr/lib/squid/security_file_certgen -s /var/lib/squid/ssl_db -M 4MB
2024/04/09 22:08:41| Processing: acl step1 at_step SslBump1
2024/04/09 22:08:41| Processing: ssl_bump peek step1
2024/04/09 22:08:41| Processing: ssl_bump bump all
2024/04/09 22:08:41| Processing: ssl_bump splice all
2024/04/09 22:08:41| Processing: coredump_dir /var/spool/squid
2024/04/09 22:08:41| Processing: refresh_pattern ^ftp:          1440    20%    10080
2024/04/09 22:08:41| Processing: refresh_pattern ^gopher:       1440    0%     1440
2024/04/09 22:08:41| Processing: refresh_pattern -i (/cgi-bin/|\?) 0    0%     0
2024/04/09 22:08:41| Processing: refresh_pattern \/(Packages|Sources)(|\.bz2|\.gz|\.xz)$ 0 0% 0 refresh-ims
2024/04/09 22:08:41| Processing: refresh_pattern \/Release(|\.gpg)$ 0 0% 0 refresh-ims
2024/04/09 22:08:41| Processing: refresh_pattern \/InRelease$ 0 0% 0 refresh-ims
2024/04/09 22:08:41| Processing: refresh_pattern \/(Translation-.*)(|\.bz2|\.gz|\.xz)$ 0 0% 0 refresh-ims
2024/04/09 22:08:41| Processing: refresh_pattern .              0       20%    4320
2024/04/09 22:08:41| Requiring client certificates.
2024/04/09 22:08:41| Loaded signing certificate: /C=RU/ST=Moscow/L=Moscow/O=Internet Widgits Pty Ltd
2024/04/09 22:08:41| Not requiring any client certificates

command sudo squid -k reconfigure

2024/04/09 22:09:41| Processing Configuration File: /etc/squid/squid.conf (depth 0)
2024/04/09 22:09:41| Processing Configuration File: /etc/squid/conf.d/debian.conf (depth 1)
2024/04/09 22:09:41| Starting Authentication on port 192.168.0.110:3129
2024/04/09 22:09:41| Disabling Authentication on port 192.168.0.110:3129 (interception enabled)
2024/04/09 22:09:41| Starting Authentication on port 192.168.0.110:3128
2024/04/09 22:09:41| Disabling Authentication on port 192.168.0.110:3128 (interception enabled)
2024/04/09 22:09:41| ERROR: cannot change current directory to /var/spool/squid: (2) No such file or directory
2024/04/09 22:09:41| Current Directory is /home/nicolay
2024/04/09 22:09:41| FATAL: failed to open /var/run/squid.pid: (2) No such file or directory
    exception location: File.cc(191) open

All certificates are generated. The paths are spelled out correctly. The Internet over https does not work on the client's machine. ping is passing. iptables has rules for port forwarding in PREROUTING and INPUT from 443 to 3129 and 80 to 3128. squid.config

acl localnet src 0.0.0.1-0.255.255.255  # RFC 1122 "this" network (LAN)
acl localnet src 10.0.0.0/8             # RFC 1918 local private network (LAN)
acl localnet src 100.64.0.0/10          # RFC 6598 shared address space (CGN)
acl localnet src 169.254.0.0/16         # RFC 3927 link-local (directly plugged) machines
acl localnet src 172.16.0.0/12          # RFC 1918 local private network (LAN)
acl localnet src 192.168.0.0/24         # RFC 1918 local private network (LAN)
acl localnet src fc00::/7               # RFC 4193 local private network range
acl localnet src fe80::/10              # RFC 4291 link-local (directly plugged) machines

acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http

http_port 3130
https_port 192.168.0.110:3129 intercept ssl-bump cert=/etc/squid/squidCA.pem generate-host-certificates=on dynamic_cert_mem_cache_size=4MB
http_port 192.168.0.110:3128 intercept

sslcrtd_program /usr/lib/squid/security_file_certgen -s /var/lib/squid/ssl_db -M 4MB

acl step1 at_step SslBump1

ssl_bump peek step1
ssl_bump bump all

ssl_bump splice all

Help please. I'm new to linux. Squida logs and cache cannot be read. All the information on the Internet is different, but nothing helped. Actions such as clearing the cache or creating a pi file manually do not help.When I installed squid 5.7, I managed to get the Internet from the repository, but over the http protocol. The config is the same. squid 6.2 had to be installed because squid 5.7 does not want to compile on my machine. I think it has to do with the source code. The machine is on ubuntu server 22.04. I use it on a virtual machine.

7
  • Why not use the Squid package in Ubuntu? 22.04 has Squid 5.7. sudo apt install squid Commented Apr 12 at 21:27
  • Unfortunately, I not use the package of squid 5.7 because this packet hasn't compilated in my Ubuntu 22.04. It's happened the error during compilating. sudo apt install squid not installed squid with ssl. I need the package with ssl to the Internet could work over the https protocol. Commented Apr 13 at 7:16
  • 1
    Ah yes, I forgot the SSL part — try sudo apt install squid-openssl. Commented Apr 13 at 7:55
  • You built the package yourself so you need to set up the redirected directory structure too. "ERROR: cannot change current directory to /var/spool/squid: (2) No such file or directory" indicates that you need to create this directory. I would expected this to have been mentioned in the Installation instructions, or even handled within make install Commented Apr 13 at 8:45
  • Yes, I created directory /var/spool/squid manually. Error disappeared, but error "FATAL: failed to open /var/run/squid.pid: (2) No such file or directory exception location: File.cc(191) open" saved. I'm not know, what do about it. Nothing help. Unfortunately, it hasn't been mentioned in the installation instructions. Commented Apr 13 at 8:53

1 Answer 1

0

I helped the following decision. I have managed to install squid by command

sudo apt install squid-openssl

before I have updated the repository. It was installed the package of squid 5.7 without assembling from the sources. Configurating squid 5.7 has been finished successfully. Perhaps, sources is bad. I don't know, there had the deb package of squid 5.7 with SSL. I thank greatly Stephen Kitt for hit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .