I am trying to install Gnome on a freshly installed FreeBSD using the ports.

I am stuck with an error message that says:
Checking for headers required to compile python extensions ... not found
Then it fails unexpectedly.

I've tried to re-install python27 and that didn't help.

What could possibly be the problem?

I am running FreeBSD 9.1; I tried to install gnome by following the FAQ I simply cd /usr/ports/x11/gnome2 then I ran make install cleanand as for the configs, I left them unchanged; by checking make config I have two unselected options:

As for the output of python2.7-config --includes I got the following:
-I/usr/local/include/python2.7 -I/usr/local/include/python2.7

  • Which port are you using? (e.g. latest port tree, portsnapped today, from where, e.g. /usr/ports/devel/gnome-common/ ) Which options have been set (e.g. run make config). Which FreeBSD version? What is the output of python2.7-config --includes ? ...
    – Hennes
    May 27 '13 at 20:27
  • Excuse me for the lack information, please check my edit.
    – Fingolfin
    May 27 '13 at 22:44

You are missing header files necessary for compilation of Python extensions which are Gnome dependency. That should not happen if you were following handbook and use stable branch. You do not really provide enough information to troubleshoot the problem.

  • I tried to follow the FAQ, not the handbook, you're right. I've edited my post to include more information; kindly check it out.
    – Fingolfin
    May 27 '13 at 22:45

The problem, as the error noted was that 'make' was looking for the pth file. I fixed it by cp /usr/local/include/pth /usr/local/include/python2.7
I have python2.7 installed instead of 2.6

Of course this is a work-around and not a serious solution to the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.