2

I have rsnapshot taking backups for me. However, each backup is the full size of the source data. It is not making hard links and instead is making new copies of ever single (unchanged) file on every instigation. I have verified that new files are being created in each backup by checking the inode numbers against each other and also by counting hardlinks (there's none).

The problem seems to be occurring at the rsync stage. rsync looks to be transferring every file at each instigation. The reason is ">f..T......", so to my understanding, it is transferring and creating a whole new file based on a differing timestamp to the backup. In fact the timestamps are significantly different, e.g. on the local system:

Access: 2024-03-18 10:14:28.285098766 +0000
Modify: 2023-11-23 21:04:36.000000000 +0000
Change: 2024-03-10 21:11:26.107904822 +0000
Birth: 2023-12-02 19:22:02.022412357 +0000

and the same file on the backup:

Access: 2024-03-18 10:14:29.369122130 +0000
Modify: 2024-03-18 10:14:30.609148859 +0000
Change: 2024-03-18 10:14:31.817174900 +0000
Birth: 2024-03-18 10:14:29.369122130 +0000

The upshot of this is that each backup takes forever and takes a huge amount of disk space, precisely the opposite of what I expect.

I believe I can fix this by adding --time to the rsnapshot/rsync configuration to "correct" the timestamps on the backup. But that differs how it should be working "out of the box" so I'm reluctant to do it.

My specific questions are:

  1. Are the timestamps in the backup wrong in this context and what should they actually be?
  2. What could have gone wrong here? I feel I may have missed a step in creating the first ever backup e.g. the first backup should have had --time.
  3. Is adding --time to the config a bad idea, given it's not already there by default?
2
  • Please include your rsnapshot configuration file. There should definitely be -t (--times) in there somewhere - even if implied by -a (--archive) Mar 20 at 0:53
  • 1
    This is the prompt I needed to figure out what the problem was. I've answered my own question for reference.
    – Dansk
    Mar 20 at 12:29

1 Answer 1

1

To answer my own question:

The problem was entirely caused by not having --times or an analogue in my rsnapshot.conf

Specifically, the default rsnapshot.conf (via github) offers #rsync_short_args -a and while I had enough sense to un-comment this my version was rsync_short_args -r, (--recursive) which gets me all my files copied to the backup but with an unsuitable time stamp as shown in the original question.

I've also checked that the default rsnapshot.conf, as downloaded with my distro, has -a so we will pass this incident off as entirely my fault.

1
  • Ah, yes. The default was the commented out version (-a) but you replaced that with just -r. That loses -t and so you don't get the modification times copied across. Thank you for providing a solution as it may help others in the future Mar 20 at 15:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .