0

I've installed Windows and Ubuntu 22.04 on two separate drives.

Windows always boots fine. However, if I want to switch over to Ubuntu, after restarting the computer and selecting the Ubuntu boot option, it will load for a little longer than usual, show me the home screen, and then shutdown.

  • I've tried using the nomodeset parameter when booting ubuntu, but that does not seem to work. Secure boot is off.

  • I've reinstalled ubuntu multiple times, no dice.

  • What's more, my bootable USB stick is failing in the same way.

Any ideas what Windows is doing that is causing Ubuntu to fail?

It's aGgigabyte motherboard and an nVidia graphics card. Unfortunately, I cannot install BootRepair. When I open the terminal in recovery mode and connect to the internet it shuts down.

4
  • 1
    What brand/model computer? What video card/chip? If you are getting to home screen, not really a boot issue, but perhaps report will show something in configuration. Please copy & paste the pastebin link to the BootInfo summary report ( do not post report), do not run the auto fix till reviewed. Use often updated ppa version with your USB installer or any working install over somewhat older ISO. help.ubuntu.com/community/Boot-Repair You should not need to run fix, just report.
    – oldfred
    Commented Mar 17 at 21:51
  • It's a gigabyte motherboard and an nvidia graphics card. Unfortunately, I cannot install BootRepair. When I open the terminal in recovery mode and connect to the internet it shuts down:/ Commented Mar 18 at 22:42
  • I disabled NetworkManager with sudo systemctl disable NetworkManager.service from the recovery terminal and now it's not shutting down on me! Super stoked! I'll update this thread once I learn more. Commented Mar 18 at 23:36
  • If nVidia, did you boot live installer in Safe Mode? And then install optional extra/restricted drivers to get nVidia driver installed? If not from recovery mode you can install nVidia driver. askubuntu.com/questions/1478024/… ubuntu-drivers list --gpgpu Available see recommended driver.
    – oldfred
    Commented Mar 19 at 16:52

1 Answer 1

0

It seems that the the default Windows driver for my Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller was somehow being loaded by Ubuntu on startup, instead of the Ubuntu version.

I'm unsure why this was happening, but disabling NetworkManager with sudo systemctl disable NetworkManager.service in the recovery terminal allowed me to successfully boot without crashing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .