0

I'm trying to get to grips with Incus, because it looks like it is a fork of Canonical's LXD, which I can run fairly easily on Debian 12 with a deb package, rather than using snaps.

I have it all set up in a virtual machine on my KVM, running with both a basic directory based storage pool, and a zfs storage pool. I have spun up a test container called test that I want to take a stateful snapshot of, but it tells me that:

To create a stateful snapshot, the instance needs the migration.stateful config set to true

enter image description here

After reading the documentation on configuring an instance's options, I have tried running these various commands (the first being the one that I think is the most likely to be correct):

incus config set test migration.stateful=true
incus config set test config.migration.stateful=true
incus config set test.migration.stateful=true
incus config set migration.stateful=true

... but I always get an error message similar to below about an unknown configuration key:

Error: Invalid config: Unknown configuration key: migration.stateful

I have also tried setting the option through the YAML configuration as shown below:

enter image description here

... but it just gets stuck on "Processing..."

enter image description here

How is one supposed to enable stateful snapshots of incus linux containers? Perhaps this is just not possible because I am running inside a virtual machine, rather than the physical box?

1 Answer 1

0

In the end I tested out incus on a physical box, and did not experience this issue. I would recommend that if someone is using Incus with the goal of virtual machines rather than just containers, that one does this on a physical host.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .