3

I wish you could help me with this matter which is WiFi hard blocked in my Linux machine and can't get the WiFi up.

My device is an HP Pavilion G6 and WiFi card is Ralink 5390; the default of the manufacturer.

The story begin when I have dual booted my Windows and ParrotOS distro my WiFi was working perfectly fine in both OS's I don’t know why but someday my WiFi decided to stop in every Linux thing!

When you type the rfkill list all command in the terminal you will see response like this

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Here what i did.

I have read every forum in the internet and tried every solution possible for it.

  • Like turning off the battery and AC cable.
  • Tried to boot every Linux distro with usb bootable iso (Ubuntu, Debian, arch Linux, core Linux, fedora, LinuxMint and many many more ).
  • Tried to removing the pin 20 in my wireless card.
  • Tried to BlackList WMI and many more things.
  • Tried to restore the bios settings, it doesn't really have that much of a setting.
  • Tried to removing RF-kill and reinstall it (I don't know what I'm doing anymore)
  • Tried to turn off the Fast boot setting in Windows.

And nothing has worked!

Note that the WiFi is working fine in the Windows system and no issues at all.

I really need it and can't afford a new WiFi adapter it's too much expensive in my city.

7
  • 2
    There should be a small LED indicating the WiFi state in or very near the F12 key at the top row of the keyboard. What is the color of that light? (it might be white, dark, or amber/yellow)
    – telcoM
    Mar 15 at 17:09
  • Have you tried kernel 6.8? Mar 15 at 17:22
  • @telcoM The LED light glows red, Through pressing it does nothing Mar 15 at 17:37
  • @ArtemS.Tashkinov after running uname -r i knew my kernel is the latest for ParrotOS which is 6.5.0-13parrot1-amd should i try another distro that has the 6.8 Kernel version? Mar 15 at 17:40
  • You must absolutely be able to install 6.8 in your distro. Someone has to be building mainline kernels for it. Google for it. I'm using Fedora, there's no such issue here. Mar 15 at 17:48

1 Answer 1

4

The red light at the F12 key indicates that the hardware/firmware-based RF-killswitch is disabling the WiFi transmitter.

Try pressing the F12 key while the system is starting up, before it reaches the Linux bootloader or before selecting the kernel to boot with, either alone or together with the Fn key. If you can get the light to either turn off or become white, that should fix the problem.

If the RF-kill key is handled by the ACPI firmware and the ACPI negotiation of the Linux kernel screws up the RF-killswitch key event handling so the killswitch cannot be toggled while Linux is running, there is a chance it might work better at boot time before the Linux kernel is not yet loaded.

1
  • Thank you so much for your answer but unfortunately it didn't help much, I will tell you what happened to me i tried this method months ago and now as you mentioned it, i constantly pressed the wifi button in this case it's the F12 action key while the system is starting up and nothing happens i also tried holding it while/before booting or even entering the boot menu. None of these worked and the issue remains. Mar 15 at 20:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .