0

I have an Orange Pi 5, an arm64 SBC running Joshua Riek's Ubuntu 22.04.4 for RK3588 (link to project).

I'm trying to build Duckstation, a PS1 emulator, which depends on Qt 6.6.2. The latest arm64 Qt version I have available through apt is version 6.2.4.

I'm building Qt 6.6.2 from source, but I'm having issues linking the built library to the Duckstation cmake build.

Building Qt 6.6.2 from git

The Qt installer application is not available for arm64, so I followed Qt's documentation on how to build Qt6 from git, found here. The steps I have taken are as follows:

  1. Clone the Qt6 repository and switch to 6.6.2 branch
$ git clone git://code.qt.io/qt/qt5.git qt6
$ cd qt6
$ git switch 6.6.2
  1. Initialize the submodules with init-repository script
$ perl init-repository
  1. Create a build directory and configure
$ mkdir build && cd build
$ ../configure

I left the -prefix attribute out, by default it will be set to /usr/local/Qt-6.6.2

  1. Build the whole Qt6 library and install
$ cmake --build . --parallel $(nproc)
$ sudo cmake --install .

Building the full library takes over an hour on this platform. After installing, the contents of the directory /usr/local/Qt-6.6.2 look like this:

enter image description here

Building Duckstation

Following the build instructions on Duckstation's readme, here are the build steps

  1. Clone the repository
$ git clone https://github.com/stenzek/duckstation.git duckstation
$ cd duckstation
  1. Create a build directory and configure
$ mkdir build
$ cmake -Bbuild -DCMAKE_BUILD_TYPE=Release

When trying to configure the build, I'm getting an error locating the Qt 6.6.2:

enter image description here

How do I link the built library to the CMake build?

I have tried creating an ldconfig file /etc/ld.so.conf.d/Qt-6.6.2.conf which contains

/usr/local/Qt-6.6.2/bin
/usr/local/Qt-6.6.2/lib

After creating the file, I ran sudo ldconfig.

If it's not a linking issue, am I installing the Qt6 to a wrong location, or missing some critical configuration step in the build?

As a sidenote: I'm able to build Duckstation successfully by patching the required Qt version to 6.2.4 and by modifying the sources a bit, but I'd like to be able to build the main branches, for handling updates more easily etc.

3
  • Although the Linux build instructions appear to assume that Qt6 will be in a standard location, if you scroll down to the macOS section it mentions a -DQt6_DIR cmake flag that may be helpful in this situation? Commented Mar 15 at 13:45
  • Welcome to the site. Please don't post screenshots of console output. They are often difficult to read, the content will not show up in search engine results, and contributors trying to help will have to type-copy content when trying to analyze/reproduce your problem. Instead, paste it into the question using code formatting.
    – AdminBee
    Commented Mar 15 at 14:11
  • @steeldriver Thank you, that did the trick. I'll post an answer to resolve this question
    – eeliale
    Commented Mar 15 at 17:22

1 Answer 1

1

Thank you @steeldriver for pointing out the -DQt6_DIR cmake flag.

I added the flag to the command, so it finally looked like this:

$ cmake -Bbuild -DCMAKE_BUILD_TYPE=Release -DQt6_DIR:PATH=/usr/local/Qt-6.6.2/lib/cmake/Qt6

The build files were now generated successfully and I was also able to compile the project.

When wondering how to list such directory related flags, I learned about cmake -LAH from this post. When running it at the Duckstation project's root, the Qt6_DIR entry looked like this:

Qt6_DIR:PATH=Qt6_DIR-NOTFOUND

In the future I'm hopefully able to solve build configuration issues more easily using that command.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .