9

My debian is not discoverable via its hostname in my LAN.

I have a couple of other ubuntu machines in the LAN and they are all pingable via their hostnames.

on my debian:

pi@raspberrypi ~ $ hostname
raspberrypi

on another machine in the same LAN:

ping raspberrypi
ping: unknown host raspberrypi
10

Your Ubuntu system has the Avahi daemon running while this is not the case for your Raspberry Pi. Install Avahi to solve the problem:

# apt-get install avahi-daemon avahi-discover libnss-mdns
  • jftr you probably have to use the .local domain, e.g. raspberrypi.local – Ulrich Dangel May 26 '13 at 22:04
  • When/how does Ubuntu run the daemon? I don't see anything called 'avahi' in the output of ps -x – Sridhar Sarnobat Apr 25 '14 at 5:32
  • EDIT - run service --status-all | grep avahi – Sridhar Sarnobat Apr 25 '14 at 5:33
0

Did a remove/install of avahi and insserv as suggested, rebooted the whole shebang. Worked.

If you can ping the IP address from another machine on the network, add the option -a to do a reverse lookup. I myself discovered that there's a max length of 15 chars for hostnames on my router.

ping -a 192.168.1.123
Pinging RASPBERRYPI [192.168.1.123] with 32 bytes of data:
...

As long as that doesn't tell you a name, thou shalt plough on.

0

If you have changed the hostname try installing samba on the Pi.

sudo apt-get install samba

Then try the following from your remote machine:

ping newhostname.local

And to ssh:

ssh pi@newhostname.local

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.