0

Does anyone know, how I can configure the gnome terminal emulator tilix to open a new tab automatically in a new window?

enter image description here

As you can see on the screenshot, I opened a new tab in a vertically tiled window from the path dir1/dir2/dir3/. Every new tab gets opened in the users working directory. How can I make tilix to open new-tabs in this same directory from witch I opened it?

1 Answer 1

0

Make sure that your bash or zsh shell sources /etc/profile.d/vte.sh (or whatever the exact filename is, e.g. it might be vte-2.91.sh or similar) on startup; or vte.csh if you use tcsh.

Also if your distribution didn't automatically configure your shell to source this file then please tell them to do so. It should be them configuring it, not you.

This script sets up your shell to emit the OSC 7 escape sequence whenever it prints the prompt. The OSC 7 escape sequence tells the working directory to the terminal emulator, which, in turn, uses it when opening a new terminal. I believe Tilix respects the OSC 7 information unconditionally, i.e. without being subject to a config option or such.

If you use a shell other than the ones mentioned earlier, you'll have to figure out yourself how to set up your shell to emit the OSC 7 escape sequences.

2
  • Hey egmont, thanks for your answer. Might it be possible, that the first sentence of your answer is missing its essence ;-) »Make sure that your bash or zsh shell sources /etc/profile.d/vte.sh…« …contain what? What do you recon to make sure? - THX for your time <3
    – nath
    Commented Mar 9 at 3:18
  • "sources", as in executes the built-in source command on that file. Sorry if it wasn't clear.
    – egmont
    Commented Mar 9 at 8:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .