0

I have managed to get iw reg get to show channel 44 (5220MHz) as allowed, by installing wireless-regdb and cdra Debian packages:

root@foo1:~# iw phy phy0 reg get
global
country GB: DFS-ETSI
    (2400 - 2483 @ 40), (N/A, 20), (N/A)
    (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
    (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
    (5470 - 5730 @ 160), (N/A, 26), (0 ms), DFS
    (5725 - 5850 @ 80), (N/A, 23), (N/A), NO-OUTDOOR
    (57000 - 71000 @ 2160), (N/A, 40), (N/A)

root@foo1:~# iw phy phy1 reg get
global
country GB: DFS-ETSI
    (2400 - 2483 @ 40), (N/A, 20), (N/A)
    (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
    (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
    (5470 - 5730 @ 160), (N/A, 26), (0 ms), DFS
    (5725 - 5850 @ 80), (N/A, 23), (N/A), NO-OUTDOOR
    (57000 - 71000 @ 2160), (N/A, 40), (N/A)

The cards are:

0000:01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
    Subsystem: Rivet Networks QCA6174 802.11ac Wireless Network Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 253
    ...
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
...
0001:01:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 254
    ...
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci

My wifi cards both already work as access points (using hostapd) in the 2.4GHz band, but neither will work as an AP in the 5GHz band, because of card-specific "NO-IR" flags:

nl80211: Drv Event 36 (NL80211_CMD_REG_CHANGE) received for wlan1
nl80211: Regulatory domain change
 * initiator=1
 * type=0
 * alpha2=GB
wlan1: Event CHANNEL_LIST_CHANGED (27) received
Channel list updated - continue setup
nl80211: Regulatory information - country=GB (DFS-ETSI)
nl80211: 2400-2483 @ 40 MHz 20 mBm
nl80211: 5150-5250 @ 80 MHz 23 mBm (no outdoor)
nl80211: 5250-5350 @ 80 MHz 20 mBm (no outdoor) (DFS)
nl80211: 5470-5730 @ 160 MHz 26 mBm (DFS)
nl80211: 5725-5850 @ 80 MHz 23 mBm (no outdoor)
nl80211: 57000-71000 @ 2160 MHz 40 mBm
nl80211: Added 802.11b mode based on 802.11g information
nl80211: Mode IEEE 802.11g: 2412 2417 2422 2427 2432 2437 2442 2447 2452 2457 2462 2467[DISABLED] 2472[DISABLED] 2484[DISABLED]
nl80211: Mode IEEE 802.11a: 5180[NO_IR] 5200[NO_IR] 5220[NO_IR] 5240[NO_IR] 5260[NO_IR][RADAR] 5280[NO_IR][RADAR] 5300[NO_IR][RADAR] 5320[NO_IR][RADAR] 5500[DISABLED][RADAR] 5520[DISABLED][RADAR] 5540[DISABLED][RADAR]
nl80211: Mode IEEE 802.11b: 2412 2417 2422 2427 2432 2437 2442 2447 2452 2457 2462 2467[DISABLED] 2472[DISABLED] 2484[DISABLED]
Channel 44 (primary) not allowed for AP mode, flags: 0x16073 NO-IR
wlan1: IEEE 802.11 Configured channel (44) not found from the channel list of current mode (2) IEEE 802.11a
wlan1: IEEE 802.11 Hardware does not support configured channel
  • Can I make my wifi cards work as access points in the 5GHz band by changing the cards' regulatory domains?
  • If so, how to I change their EEPROM regdomain from 0x69 and 0x64 to whatever represents GB?
  • Or can I give the looser GB restrictions priority over the cards' regulatory domains?

1 Answer 1

2

Long story short: you can't! A card will never allow you to pick a location that has more rights than it's currently programmed to grant; that's a requirement of these regulations. (And these regulations are actually there for good reason; a single rogue network card can ruin a public service for millions, when it interferes with weather radars.)

Of course, there's some … flexibility when you're the author of a driver, and because all linux drivers are inherently open source, you can modify the driver and might be able to reprogram the region. However, that's only possible for a few select cards, and it's, again, illegal, and morally questionable, if you're not actually in the place you want to program the card to be in. Your favorite search engine is your friend there; but again, even if this is possible for your card, it will involve modification of a kernel driver, compilation, loading of the same, with all that entails.

2
  • Why would the cards have such restrictive settings? Both of them have [NO-IR] for every 5GHz band, so I assumed that it was a fixable issue.
    – fadedbee
    Feb 26 at 16:32
  • 1
    That's the thing, this sounds like your card was shipped without DFS support, which is needed Feb 26 at 17:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .