1

Some basic details:

archlinux 3.9.3-1
xmonad 0.11
urxvt 9.18

I can get urxvt to load my desired font manually using:

urxvt -fn "xft:Ubuntu Mono"

However, I'm unable to get this font to load through ~/.Xdefaults - Here's what I have at the moment:

Xft*dpi: 96
Xft*antialias: true
Xft*rgba: rgb
Xft*hinting: true
Xft*hintstyle: hintslight

URxvt*transparent: true
URxvt*shading: 40
URxvt*saveLines: 12000
URxvt*foreground: White
URxvt*background: Black
URxvt*scrollBar: false
Urxvt*font: xft:Ubuntu Mono
Urxvt*boldFont: xft:Ubuntu Mono

All other urxvt settings load fine, except the font. I've tried many different combinations like: xft:Ubuntu Mono:pixelsize=14:style=regular etc, but nothing seems to work.

I've tried xrdb -merge ~/.Xdefaults, xrdb -load ~/.Xdefaults, and restarting X entirely. I've also tried these settings in ~/.Xresources, however urxvt seems to ignore those settings entirely. What am I missing?

8

Use URxvt instead of Urxvt. It's case sensitive.

URxvt*font: xft:Ubuntu Mono
URxvt*boldFont: xft:Ubuntu Mono
  • Jee wizz.. I feel silly. Thanks, thats exactly what is was. – archmike May 25 '13 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.