5

I cannot find where I can set keyboard shortcut for switching languages.

Update:
New problem: I cannot set Alt+Shift combination for that.

2 Answers 2

8

From language-bar select "Keyboard Layout settings", "Region and Language Settings" or the like. Then select:

Layouts -> Options ... -> Key(s) to change layout

Check off desired key-combination.


If language-bar is not present go to:

Menu -> (System tools)* -> System Settings -> Keyboard -> Typing

click on "Layout Settings".

*Depending on menu layout "System Settings" is at top-level of menu or in sub of System tools.


Or, from command-line, Run menu etc., execute:

gnome-control-center keyboard

click on "Layout Settings".


Tested on system with Gnome3/Cinnamon.

EDIT :

You are not following the instructions. I try again with more pictures ;)

Pictures from Gnome 3 Classic, but was same for Gnome 3 / Cinnamon.

1. Menu -> (System tools)1 -> System Settings – Select Keyboard:

1 Depending on menu layout.

Quickest / fastest way could be:

$ gnome-control-center keyboard

enter image description here

2. Select "Layout Settings":

enter image description here

3. Select Layouts
4. Select Options…

enter image description here

5. Select Key(s) to change layout
6. Check of desired key combination. And make sure there are no other selected (unwanted) combinations.

enter image description here

Note that for Cinnamon 3.2.7 (Linux Mint 18.1) The option is called "Switching to another layout"

8
  • Thanks, I found it, but cannot set alt+shift combination. Only with some another key. Can I do this with some config?
    – Mykytak
    Commented May 25, 2013 at 11:24
  • What do you mean by cannot? It isn't there or …? Here it works with both Alt+Shift, Left Alt + Left Shift etc.
    – Runium
    Commented May 25, 2013 at 11:29
  • I try typing alt+shift but nothing happens. Alt, Control and Shift keys set only if I use it with some another button.
    – Mykytak
    Commented May 25, 2013 at 11:37
  • You have to check it of with your mouse. Also remember to remove any old selections. Here it works with e.g. Left Alt alone.
    – Runium
    Commented May 25, 2013 at 11:47
  • My keyboard settings looks like this: 3.bp.blogspot.com/-nZCRySMxpMc/T9VAH3nKrpI/AAAAAAAADew/…
    – Mykytak
    Commented May 25, 2013 at 11:54
6

I don't use Cinnamon so this might not work for you, but in vanilla Gnome 3.6 you could do this either via terminal:

gsettings set org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher alt-shift-l

or via dconf-editor, navigating to org > gnome > settings-daemon > peripherals > keyboard and entering alt-shift-l as a value for the input-sources-switcher key:

enter image description here

In Gnome 3.8 they have re-added this feature to Settings > Keyboard > Shortcuts, via an additional section called Typing:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .