0

I have a PC with a NVMe SSD (/dev/sdb) and a SATA one (/dev/sda). On NVMe SSD there is only Windows 11, on SATA one I had only Ubuntu, until today. This morning I have installed Manjaro Linux with custom partioning installation on /dev/sda alongside Ubuntu. The problem is that GRUB does not show me Manjaro OS but only Ubuntu and Windows (as always it has done). The only way to load Manjaro is to connect Live USB Image and select the Detect EFI bootloaders entry. Here I found these:

Detect EFI Bootloaders

Selecting first choice, it boots Manjaro correctly. I searched on net for all the afternoon and I tried reinstalling GRUB with grub-install command both on Manjaro and Ubuntu but with no effect. I tried also update.grub and sudo grub-mkconfig -o /boot/grub/grub.cfg in vain. Last attempt was efibootmgr which reports:

BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0000,0001,0003,0004
Boot0000* Windows Boot Manager
Boot0001* manjaro
Boot0002* ubuntu
Boot0003* UEFI OS
Boot0004* UEFI: KingstonDataTraveler 3.0PMAP

I tried to change boot order and timeout but after restart it returns as before.

4
  • Is your mainboard manufacturer MSI by any chance?
    – eyoung100
    Commented Feb 20 at 17:31
  • It is a Mini PC bought on the famous ecommerce, so it is a custom montherboard. Anyway the UEFI/BIOS is an AMI.
    – TechRevo
    Commented Feb 20 at 17:45
  • Well it sounds like your firmware may be a bit buggy. Read this blog, otherwise use your boot menu, usually F11 or Delete on your keyboard while the system is booting.
    – eyoung100
    Commented Feb 20 at 17:56
  • Have you tried adding a Manjaro entry to Ubuntu's grub's 40_custom. You can try a typical UEFI entry (like Windows chainloader) or a full grub boot stanza to directly boot Manjaro, by copying the entry in Manjaro's grub. Some examples: ubuntuforums.org/…
    – oldfred
    Commented Feb 20 at 18:21

2 Answers 2

0

You can source the Manjaro grub.cfg into Ubuntu grub.

Add the following line to /etc/grub.d/40_custom:

menuentry 'Manjaro grub menu' {
search.fs_uuid the_uuid_of_the_root_partition root hd1,gptX
set prefix=($root)'/grub'
configfile $prefix/grub.cfg
}

gptX is the manjaro root partition, then sudo update-grub

0

I found the issue. This was due my UEFI firmware has in Boot Menu an other entry to choose boot loaders order. So each time I restarted the computer, even if I have used efibootmgr to change it, the firmware resets it to previous configured order.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .