0

I have two network interfaces on a client PC, one wired, one wireless. The wired is connected directly to a server PC running DHCP, which gives the client PC a 10.0... address. The client PC also connects to a wireless router, which gives it a 192.168... address. This was all set up and detected automatically by NetworkManager. I am able to ping the server PC and wireless router.

The problem is I want to use the wired connection as a LAN only, and the wireless for WAN access to the wider Internet. But NetworkManager thinks the opposite, and tries to use the LAN to go to the outside Internet. If I unplug the cable it correctly uses wireless. But I'd like to have them both connected at the same time.

I'm running Debian unstable if that matters.

Is there some way to configure this?

1
  • Modify your routing table so the WAN is the default route & traffic to the 10.0... network is routed through the LAN.
    – Garnet
    Feb 16 at 14:28

1 Answer 1

1

Ok, I figured it out by looking at the answer to this question:

NetworkManager changes default routing policy

To summarize:

Open up NetworkManager's graphical connection editor

$ nm-connection-editor

In the GUI:

  • Click on "Wired connection 1".
  • Click on the gear button for settings.
  • Click on the "IPv4 Settings" tab.
  • Click on the "Routes..." button.
  • Check the "Use this connection only for resources on its network" box.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .