I try to get postfix and dovecot up and running.

I have a little problem with the mail-box path that connects both.


virtual_mailbox_base    = /var/vmail
virtual_mailbox_domains = mydom.org

This creates a file


as an mbox-file if I send to [email protected]. The sent mail is inside of that file.

So far - so good.

But in dovecot I have this for a virtual user.

[email protected]:{PLAIN}mysecret:5000:5000::/var/vmail/mydom.org::userdb_mail=mbox:~/%u

That creates

/var/vmail/mydom.org/[email protected]/inbox

after successful login.

So my POP3-client finds always an empty mailbox. If I copy the postfix-mailbox to the inbox-file, then POP3 gets the message.

How do I get dovecot to use the postfix-mailbox or postfix to use the dovecot-file? I tried several settings in dovecot but I did not get it going to use the posfix-file as it is.


1 Answer 1


I adapted vmaps of Postfix to match the dovecot-requirements.

Needed to

postmap vmaps

to make it work in Postfix - only a restart is not enough.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .