0

I am trying to install Debian 12.4.0 alongside Windows 10 in my Asus Zenbook Flip 15 (UX564). Despite having prepared 100 GB of free space for Debian installation (see first picture), the Debian installer fails to detect this unallocated space when I do the guided partitioning by using the largest continous free space (see second picture).

Current disk partitions

Failed to detect the free space

If I try to do the Manual partition, the Debian installer detects my disk but it shows neither the Windows partition nor the unallocated free space (see third picture).

Manual partitioning

My Asus Zenbook Flip 15 is operating in UEFI BIOS mode, and my disk is an Intel Optane H10 with SSD 512GB. Checking my disk, I found that it is a basic disk (not dynamic disk) with a GPT partition style. Additionaly, the Fast boot and the Secure boot are disabled as recommened to install debian alongside Windows.

I am new installing linux so I don't know how to solve it. I have found similar problems in different forums on the web. However, the solutions they propose are related to having a dynamic memory, a MBR partition style, or using the Legacy boot mode instead of the UEFI mode. I have also disabled the VMD controller to change the SATA mode operation from RAID/RST to AHCI, but by doing this the Debian installer doesn't detect my disk at all.

If anyone has encountered a similar issue or knows how to resolve it, I would greatly appreciate your guidance. Additionally, any suggestions for troubleshooting steps would be welcome.

Thank you in advance for your assistance!

EDITED:

Debian installer detects free space on the USB drive but not on my laptop drive if Windows fast start is disabled (see picture).

enter image description here

8
  • Do you have Windows fast start up on? That sets hibernation flag, preventing the NTFS partitions from being correctly seen? askubuntu.com/questions/1436555/…
    – oldfred
    Feb 11 at 21:12
  • I disabled Windows fast start up as you suggested, but the Debian installer only detects free space on the USB drive. I edited the original post to include a picture showing this change. Feb 11 at 21:58
  • Several models of Asus with Optane required Optane to be disabled. Some have then used the second NVMe drive as / ( but now with snaps even 30GB is not large. I use Kubuntu and prevent snaps from installing and have used 14GB of my 30GB /. But Ubuntu with snaps would need more. askubuntu.com/questions/1162452/… & ubuntuforums.org/showthread.php?t=2458373 & askubuntu.com/questions/1162452/… Intel has obsoleted Optane. Some just add another NVMe drive.
    – oldfred
    Feb 12 at 4:05
  • I read from the links you provided that I have to switch the SATA mode from Intel Optane to AHCI. However, in my BIOS menu, I don't have any option to change this. I found a youtube video explaining that disabling the VMD controller switches the SATA Mode Operation from RAID/RST to AHCI. I disabled the VMD controller, but when I restarted my laptop, Windows couldn't boot, and the Debian Installer couldn't detect my laptop drive. Based on your links, I assume I don't have any AHCI or NVMe drivers, right? Feb 12 at 10:08
  • Windows typically requires you to install a AHCI driver to boot it in AHCI mode. I have a Dell with 11th Gen Intel and only one NVMe drive. I was surprised it installed using Kubuntu & VMD driver. I actually forgot to change to AHCI as I have suggested to others many times. Some have posted they just removed the Optane card and replaced with standard NVMe drive. Asus Zenbook UX425EA w/Intel Iris Xe Graphics - turn off optane with Windows Optane app ubuntuforums.org/showthread.php?t=2458373 removal (setuprst.exe and setupoptanememory.exe - both from Dell
    – oldfred
    Feb 12 at 15:04

1 Answer 1

0

At long last, I was finally able to install Debian 12.4.0 alongside Windows 10 on my Asus Zenbook Flip 15 (UX564). Below I list the recommendations I followed:

After applying this configurations, the Debian installer can recognize my Windows partition and the unallocated space in the drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .