0

Am trying to set up a USB 4G modem on a Raspberry Pi using NetworkManager, but it doesn't seem to be detected.

Here are the details of my setup:

Raspberry Pi model: 4

USB 4G Modem: zte mf833u1

Operating System: Rasbian Bookworm

Steps I've Taken:

Checked USB connection: The modem is correctly connected to the Raspberry Pi. Listed USB devices: lsusb shows the modem as "Bus 001 Device 006: ID 19d2:1405 ZTE WCDMA Technologies MSM DEMO Mobile Boardband." Checked ModemManager status: It's running (sudo systemctl status ModemManager).

Issue: Despite these steps, the USB modem is not being detected by NetworkManager (nmcli device status does not list the modem). Result of "mmcli -L": No modems were found

Any assistance or insights into resolving this issue would be greatly appreciated.

2 Answers 2

1

Information found in arch-linux wiki: You need the usb-modeswitch package to be installed and the cdc_ether kernel module to be loaded:

sudo apt install usb-modeswitch
sudo modprobe -v cdc_ether
6
  • successfully installed usb-modeswitch and loaded the cdc_ether kernel module on the Raspberry Pi. Where and how to set up the PIN code and APN for the SIM card in this context? Commented Feb 10 at 22:36
  • 1
    @user3607022 see here how to remove pin and set the APN wiki.archlinux.org/title/Mobile_broadband_modem
    – GAD3R
    Commented Feb 11 at 10:09
  • Thanks. That article however seems to focus on treating the usb modem as a modem attached on usb (ttyUSB*), however in this case now it's attached to eth1 and recognized as an ethernet interface. Furthermore, it mentions disabling the pin on the sim card but that's not a good solution in this case as it'll be in a remote location. Tried sending AT commands to eth1, didn't work. Accessing the web interface (192.168.0.1) to enter pin worked, but doesn't persist after reboot. Tried curling the web interface (curl -d "...etc..." http://192.168.0.1/goform/goform_set_cmd_process), didn't work. Commented Feb 11 at 11:08
  • 1
    @user3607022 Hi . Asking a new question may be more helpful for you.
    – GAD3R
    Commented Feb 11 at 11:10
  • 1
    @user3607022 Sorry I have not seen your question.
    – GAD3R
    Commented Feb 11 at 11:12
1

Look at the output of lspci -k and check if a kernel module is loaded for that device. The hardware support for wireless hardare on RPi is spotty and I had to compile my own kernel modules a few times before for those.

1
  • Thank you for your suggestion. Unfortunately, the output of lspci -k didn't reveal any specific kernel modules related to the USB modem. It seems like the USB controller and PCIe bridge are identified, but not the modem itself. Nonetheless, your advice to check for kernel modules was insightful and appreciated. Commented Feb 10 at 22:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .