0

So, I am facing a problem with several Rpi units I have here.

Most of the time they work fine, but after several days, the LTE modem (TELIT 910C1-LA) stops working with no reason.

Luckily, I could reproduce the problem and saw what is happening before it:

The system has booted I have a HTML page that exhibits the modem status LTE Modem had the status: "Connecting" LTE Modem has changed the status to "Disconnecting" LTE Modem has changed the status to blank I have connected trought SSH to the Rpi and run some commands to check what was happening: Comands I tried

mmcli -L has returned "No modems were found" mmcli -m 0 has returned "couldn't find modem at " qmicli -d has returned the ICCID of the SIM Card It seems to me that the modem has dropped, then I have connected SSH again an checked the lsusb: lsusb show the modem in the usb list

It is possible to see that the "Telit Wireless Solution" is conencted on the USB Do you guys has any tips on that? I am kind of newbie to Linux OS, I know how to execute basic commands, but I am definetly not an advanced user.

Thanks in advance!

I did not tried anything, as I don't want the problem to go away before further analisys.

This is an intermitent problem and I want to understand why it is happening and how can I fix it.

1 Answer 1

0

You could try resetting the modem with usbreset when you detect it is no longer working. Something like this:

ping -q -c 1 1.1.1.1 || usbreset 1bc7:1201

This example sends a ping request to 1.1.1.1 and if it fails (there is no answer) then usbreset is run, selecting the device by vendor:id.

1
  • Thank you, Eduardo! I could restabilish the conection using usbreset. Now I am implementing a script to check the connection and reset the modem once a day. Feb 16 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .