0

I have Ubuntu 20.04 running on Raspberry Pi4 and have a 5G HAT to get it connected to the internet.

I have a wwan0 network interface with the IP. Now I'd like to make this network available as an access point to other devices. I tried to use a netplan, but it seems to work only with eth0 interface. Is there any way to make it work?

2
  • hm, netplan works with any interface name, so that's probably not the problem! But I'm not sure you'd need netplan for this at all? We don't really know what you've been trying, would you mind explaining that? It might also be useful to know what kind of WLAN network interface you're using! Feb 9 at 13:23
  • sure, i'm using SIM8200EA-M2_5G_HAT as a network interface, it have been configured as wwan0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1500. in netplan yaml i was trying to define it in this way: network: version: 2 renderer: NetworkManager ethernets: wwan0: dhcp4: true wifis: wlan0: dhcp4: true access-points: "Raspberry": password: "password" mode: ap Feb 9 at 16:54

1 Answer 1

1

To configure an access point on Ubuntu install the linux-wifi-hotspot.

sudo add-apt-repository ppa:lakinduakash/lwh
sudo apt install linux-wifi-hotspot

To use the GUI: wihotspot.

To Use the CLI create_ap --help see create_ap.

To get the same subnet:

git clone https://github.com/oblique/create_ap.git
cd create_ap/

Edit create_ap.conf, nano create_ap.conf:

CHANNEL=default
GATEWAY=100.105.160.1 # set your gateway
WPA_VERSION=2
ETC_HOSTS=0
DHCP_DNS=gateway
NO_DNS=0
NO_DNSMASQ=0
HIDDEN=0
MAC_FILTER=0
MAC_FILTER_ACCEPT=/etc/hostapd/hostapd.accept
ISOLATE_CLIENTS=0
SHARE_METHOD=nat
IEEE80211N=0
IEEE80211AC=0
HT_CAPAB=[HT40+]
VHT_CAPAB=
DRIVER=nl80211
NO_VIRT=0
COUNTRY=
FREQ_BAND=2.4
NEW_MACADDR=
DAEMONIZE=0
NO_HAVEGED=0
WIFI_IFACE=wlan0
INTERNET_IFACE=wwan0 # set the connected interface
SSID=MyAccessPoint # set your AP name 
PASSPHRASE=12345678 # set your passphrase here
USE_PSK=0

Then run:

sudo ./create_ap --config create_ap.conf

Also, you can use the -g option to set the gateway:

sudo bash create_ap -g 100.105.160.1 wlan0 wwan0 AP PASS
9
  • should i stop it somehow, or it-s just enaugh to run the commands: sed -i 's/GATEWAY.*/GATEWAY=192.105.160.1/' create_ap.conf sudo ./create_ap options_here can i ask you where you get the Gateway ip? should i put the one assigned to wwan0? Feb 12 at 12:51
  • with the Gateway you mean the wwan0 address? than it is 100.105.160.234, if so i tried the command suggested by you, but it didn-t change a lot, i still have a wlan0 192.XX.XX.X and i can-t even ping the RPi IP from my PC, which is connected through the AP and seems to not have an internet connection. even worse, the RPi loose the DNS server settings when i initialize the AP. Feb 12 at 14:00
  • i can see the config file exactly as u updated. But once i run the create_up command the DNS server setting are getting ruined for some reason. Feb 12 at 14:38
  • yes, it didn-t hep Configuration file: /tmp/create_ap.wlan0.conf.RpdqsTUV/hostapd.conf wlan0: Could not connect to kernel driver Using interface wlan0 with hwaddr dc:a6:32:bd:08:52 and ssid "PiT" wlan0: interface state UNINITIALIZED->ENABLED wlan0: AP-ENABLED wlan0: STA 38:d5:7a:37:54:8b IEEE 802.11: associated wlan0: AP-STA-CONNECTED 38:d5:7a:37:54:8b wlan0: STA 38:d5:7a:37:54:8b RADIUS: starting accounting session 75AABD64579AF4B8 wlan0: STA 38:d5:7a:37:54:8b WPA: pairwise key handshake completed (WPA) wlan0: STA 38:d5:7a:37:54:8b WPA: group key handshake completed (WPA) Feb 12 at 14:52
  • 1
    ok, i found the root cause. it was an dnsmasq.config. I changed there listen-address=100.105.160.234 bind-dynamic dhcp-range=100.105.160.1,100.105.160.254,255.255.255.0,24h dhcp-option-force=option:router,100.105.160.234 dhcp-option-force=option:dns-server,8.8.8.8 dhcp-option-force=option:mtu,1500 no-hosts : the line 5, where dns server is defined, it was pointing to his own IP, and was not able to resolve any address, changing it to 8.8.8.8 now i can access internet from both RPi4 and from the connected device. My question is how i can make this happen automatically on script run? Feb 12 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .