0

sudo apt upgrade showing following error

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (< 2.36) but 2.37-12 is installed
 libc6-dev : Depends: libc6 (= 2.35-0ubuntu3.6) but 2.37-12 is installed
             Depends: libc-dev-bin (= 2.35-0ubuntu3.6)
 locales : Depends: libc-bin (> 2.37)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

apt --fix-broken install showing following error and the same error was shown in synaptic package manager when i tried to fix broken install

The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (< 2.36) but 2.37-12 is installed
 libc6-dev : Depends: libc6 (= 2.35-0ubuntu3.6) but 2.37-12 is installed
             Depends: libc-dev-bin (= 2.35-0ubuntu3.6)
 locales : Depends: libc-bin (> 2.37)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

sudo dpkg --configure -a command shows foloowing error:

dpkg: dependency problems prevent processing triggers for libc-bin:
 libc-bin depends on libc6 (<< 2.36); however:
  Version of libc6:amd64 on system is 2.37-12.

dpkg: error processing package libc-bin (--configure):
 dependency problems - leaving triggers unprocessed
Errors were encountered while processing:
 libc-bin

sudo apt-get install -f shows following error

Correcting dependencies... failed.
The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (< 2.36) but 2.37-12 is installed
 libc6-dev : Depends: libc6 (= 2.35-0ubuntu3.6) but 2.37-12 is installed
             Depends: libc-dev-bin (= 2.35-0ubuntu3.6)
 locales : Depends: libc-bin (> 2.37)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I have tried many things from the internet but everything shows one of these 2 or 3 errors.PLEASE HELP ME FIX IT.PLEASE,PLEASE HELP!!! THANKS

apt policy libc6 shows following output

libc6:
  Installed: 2.37-12
  Candidate: 2.37-12
  Version table:
 *** 2.37-12 100
        100 /var/lib/dpkg/status
     2.35-0ubuntu3.6 500
        500 http://in.archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu jammy-security/main amd64 Packages
     2.35-0ubuntu3 500
        500 http://in.archive.ubuntu.com/ubuntu jammy/main amd64 Packages

Is there any chance this could be fixed.I actually tried to install katoolin in my ubuntu 22.04 machine but everything went smooth till system upgrade and when it started upgrading,it showed the errors mentioned above.Please help me fix it?

TRIED TO DOWNGRADE libc6 but the command sudo apt install libc6="2.35-0ubuntu3.6" displayed following error:

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (> 2.37) but 2.35-0ubuntu3.6 is to be installed
 libc6-dbg : Depends: libc6 (= 2.37-12) but 2.35-0ubuntu3.6 is to be installed
 libc6-dev : Depends: libc-dev-bin (= 2.35-0ubuntu3.6)
 locales : Depends: libc-bin (> 2.37)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

2 Answers 2

2

You need to downgrade all the libc6-related packages simultaneously:

sudo apt install libc6{,-dev-bin,-dbg,-dev,-bin}/jammy locales/jammy

It seems you have partially upgraded to Debian unstable; other packages may be affected too.

-1

Why your system is broken?

Executing katoolin script will add the following line to your /etc/apt/sources.list:

deb http://http.kali.org/kali kali-rolling main contrib non-free

and ppa:diesch/testing (this ppa isn't harmful but it is not compatible with jammy)

To solve the problem:

First, As said in the katoolin documentation, you should remove kali repository:

Before updating your system , please remove all Kali-linux repositories to avoid any kind of problem .

sudo apt update
sudo apt --fix-broken install
2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .