0

On a brand new debian installation, when no ~/.vimrc is present, vim shows all files in the current directory when trying to open another file for editing in normal/command mode, as shown below:

vim when pressing ":e"

However, when a ~/.vimrc is present, even an empty one, I suddenly cannot see other files in the same directory.

I am looking for the vim option that I have accidentally disabled, so that I can re-enable this behavior.

1 Answer 1

4

What you are referring to is called the "wildcard menu". This shows the filnames that match the pattern under the cursor when you press Tab after :e. Since there is no pattern, all filenames are shown.

This "wildcard menu" is enabled by the wildmenu option:

set wildmenu

Or,

set wmnu

The reason this option is on when you have no .vimrc file but off when that file exists is that the option is set in defaults.vim on your system. The defaults.vim file is not used if Vim finds your .vimrc file.

The documentation for the defaults.vim file suggests that you start your .vimrc file with

unlet! skip_defaults_vim
source $VIMRUNTIME/defaults.vim

... to get the system defaults (which, in your case, would include setting the wildmenu option).

1
  • Thanks a lot, wildmenu was indeed the option I was looking for. For some reason, I couldn't find it.
    – Adama
    Jan 26 at 8:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .