0

I'm on Dell Latitude 3420, Devuan Daedalus GNU/Linux (based on Debian Bookworm, without systemd),

I connect to internet via mobile hotspot (using Android Phone's mobile data) at home and through a router installed by a service provider at office.

Recently, I have not been able to connect to internet at office, both ethernet and WiFi. WiFi and LAN icons show that they are connected to the router, but no internet access.

Can someone please help me out?

What further information would be needed from my end? I'm a Linux user since 2010. Quite used to CLI commands. Windows OS on other office PCs connect well to the router.

Please edit tags if necessary.

Regards,

EDIT

*resolvconf.conf*

# Configuration for resolvconf(8)
# See resolvconf.conf(5) for details

resolv_conf=/etc/resolv.conf
# If you run a local name server, you should uncomment the below line and
# configure your subscribers configuration files below.
#name_servers=127.0.0.1


# Mirror the Debian package defaults for the below resolvers
# so that resolvconf integrates seemlessly.
dnsmasq_resolv=/var/run/dnsmasq/resolv.conf
pdnsd_conf=/etc/pdnsd.conf
unbound_conf=/etc/unbound/unbound.conf.d/resolvconf_resolvers.conf
9
  • 2
    It would be helpful to know if you are using a static or DHCP network config, to see the IP address netamask and default route both from your Dell and your phone (temporarily switch phone's network config to "static" and it will show you the current settings)
    – symcbean
    Commented Jan 23 at 16:07
  • 1
    @GAD3R The laptop was getting connected earlier. This is just a recent issue.
    – vrgovinda
    Commented Jan 23 at 16:29
  • What is the IP address of the laptop?
    – eyoung100
    Commented Jan 23 at 19:31
  • @symcbean can you give me the exact commands?
    – vrgovinda
    Commented Jan 24 at 14:39
  • @eyoung100 how to check that?
    – vrgovinda
    Commented Jan 24 at 14:40

1 Answer 1

0

Try to install the openresolv package, edit the resolvconf.conf with the proper dns servers, and then run resolvconf -u

2
  • Thank you. please see the edits.
    – vrgovinda
    Commented Jan 27 at 13:50
  • It looks like you haven't edited it yet, you need to uncomment the name servers part and put a dns resolver in there. In the nameservers part include the opendns nameservers for example. They are very reliable resolvers. 208.67.222.222 and 208.67.220.220
    – Turdie
    Commented Jan 27 at 17:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .