0

I'm trying to block my iPhone from being used when I connect it so that I can pass it through to a VM. So far, I have this udev rule but I still get an error about the device being used whenever I try and pass it through.

blacklist ipheth
blacklist apple-mfi-fastcharge
install ipheth /bin/false
install apple-mfi-fastcharge /bin/false
SUBSYSTEM=="usb", ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="12a8", ATTR{authorized}="0"

As you can see, I have tried to deauth using the vendor and product IDs as well as disable the two modules mentioned in dmesg.

This is all I get from dmesg now. Which would indicate that what I've got is at least somewhat working, as there's no ipheth or fast charging.

Jan 21 19:56:44 carbon-14 kernel: usb 1-3: new high-speed USB device number 11 using xhci_hcd
Jan 21 19:56:45 carbon-14 kernel: usb 1-3: New USB device found, idVendor=05ac, idProduct=12a8, bcdDevice=16.01
Jan 21 19:56:45 carbon-14 kernel: usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 21 19:56:45 carbon-14 kernel: usb 1-3: Product: iPhone
Jan 21 19:56:45 carbon-14 kernel: usb 1-3: Manufacturer: Apple Inc.
Jan 21 19:56:45 carbon-14 kernel: usb 1-3: SerialNumber: xxx

What have I missed?

1 Answer 1

2

You've probably missed usbmuxd.

In systemd-based distributions, it is now configured as a static service, and udev is configured to tag any Apple iDevices with TAG+="systemd" and ENV{SYSTEMD_WANTS}="usbmuxd.service", which causes systemd to start usbmuxd.service whenever such a device is plugged in.

Since it is a static service, systemctl disable does nothing to it. You'll want systemctl mask usbmuxd.service instead.

3
  • Yup, that's got me a different error at least, so progress! I get "Error resetting device: LIBUSB_ERROR_NOT_FOUND" now Jan 21 at 20:24
  • Was that error from the VM, or still on the host side of things? It seems like something is trying to invoke a libusb-based configuration tool. Maybe an udevrule invoking usb_modeswitch?
    – telcoM
    Jan 21 at 20:37
  • That error occurs when I attempt to redirect the USB device using SPICE Jan 22 at 9:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .