0

I bought myself a new PCIe WiFi card which has a built-in bluetooth controller and got it all set up. The WiFi side of things was straightforward and has been working stably since I first installed the card nearly a year ago.

Bluetooth has never worked. I've tried troubleshooting but it's as if the card just doesn't have a bluetooth controller - hcitool lists no devices, and obviously none of the higher-level utilities are able to detect any devices either (tried e.g blueman-manager, bluetoothctl, etc.)

I'm happy to add info as/when requested, but here's some basic stuff:

Kernel version: 6.1.0-17-amd64
Debian version: Debian GNU/Linux 12 (bookworm)

Relevant lspci -nnk output:
04:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz [8086:2725] (rev 1a)
    Subsystem: Intel Corporation Wi-Fi 6 AX210 160MHz [8086:0020]

BlueZ package version: 5.66-1+deb12u1

1 Answer 1

1

It turns out this particular card comes with a USB cable in the box to plug the card into the motherboard's USB headers. When I first installed the card, I hadn't got any USB headers left on the motherboard so I put the cable back in the box and left it as a problem for future me. Future me became present me once I looked in the box for an instruction manual and remembered that I'd done this when I installed the card.

Without the USB cable plugged in, this card will work as a WiFi card but the bluetooth functionality will not work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .