1

I am configuring Kubernetes in a cloud environment.

I configured the cluster using the following command.

kubeadm init \
--apiserver-advertise-address=172.16.100.10 \
--pod-network-cidr=100.100.0.0/16 \
--apiserver-cert-extra-sans=0.0.0.0 \
--upload-certs

I wanted to install Calico, so I referenced the official website to install it.

In the custom-resources.yaml file, I changed the CIDR to 100.100.0.0/16.

# This section includes base Calico installation configuration.
# For more information, see: https://docs.tigera.io/calico/latest/reference/installation/api#operator.tigera.io/v1.Installation
apiVersion: operator.tigera.io/v1
kind: Installation
metadata:
  name: default
spec:
  # Configures Calico networking.
  calicoNetwork:
    # Note: The ipPools section cannot be modified post-install.
    ipPools:
    - blockSize: 26
      cidr: 100.100.0.0/16
      encapsulation: VXLANCrossSubnet
      natOutgoing: Enabled
      nodeSelector: all()

---

# This section configures the Calico API server.
# For more information, see: https://docs.tigera.io/calico/latest/reference/installation/api#operator.tigera.io/v1.APIServer
apiVersion: operator.tigera.io/v1
kind: APIServer
metadata:
  name: default
spec: {}

When I look at the pod status, the calico-node pod is 0/1 Running, so I checked it with describe and got the following

error: calico/node is not ready: BIRD is not ready: BGP not established with this error.

I have allowed both 0.0.0.0/179 with the firewall in the cloud console.

How do I fix this?

1 Answer 1

1

The following solution worked for me:

Check your installation crd,try to update

    nodeAddressAutodetectionV4:
      interface: eth*

to make sure your calico node binds to correct network device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .