0

I need to install SAGA GIS for some interpolations. Sadly, sudo apt-get install saga will only install version 7.3.0, but I need version 9, preferably 9.3.0.

The SourceForge repo doesn't contain Linux binaries. The wiki page on binaries mentions a Launchpad package, but the last build is from 2017.

There's also a 9.3.0 package for sid in the Debian repo, but I can't install it:

$ sudo apt install ./saga_9.3.0+dfsg-1_amd64.deb                
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Hinweis: »saga« wird an Stelle von »./saga_9.3.0+dfsg-1_amd64.deb« gewählt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 saga : Hängt ab von: saga-common (= 9.3.0+dfsg-1) soll aber nicht installiert werden
        Hängt ab von: libc6 (>= 2.35) aber 2.31-0ubuntu9.14 soll installiert werden
        Hängt ab von: libgdal34 (>= 2.1.0) ist aber nicht installierbar
        Hängt ab von: libodbc2 (>= 2.3.1) ist aber nicht installierbar
        Hängt ab von: libproj25 (>= 5.1.0) ist aber nicht installierbar
        Hängt ab von: libsaga-api9 (>= 9.3.0+dfsg) ist aber nicht installierbar
        Hängt ab von: libsaga-gdi9 (>= 9.3.0+dfsg) ist aber nicht installierbar
        Hängt ab von: libstdc++6 (>= 13.1) aber 10.5.0-1ubuntu1~20.04 soll installiert werden
        Hängt ab von: libwxbase3.2-1 (>= 3.2.4+dfsg) ist aber nicht installierbar
        Hängt ab von: libwxgtk3.2-1 (>= 3.2.1+dfsg-2) ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Thus, the only option left is compiling SAGA GIS from source. When following the compilation docs, I run into the following error:

$ cmake ../saga-gis -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr/local -DCMAKE_INSTALL_RPATH=/usr/local/lib -DPYTHON_INCLUDE_DIR=/usr/include/python3.6m -DPYTHON_LIBRARY=/usr/lib64/libpython3.6m.so -DPYTHON_EXECUTABLE=/usr/bin/python3.6 -DWITH_TRIANGLE=OFF -DWITH_SYSTEM_SVM=ON -DWITH_TOOLS_VIGRA=OFF -DWITH_DEV_TOOLS=ON -DSVM_INCLUDE=/usr/include/libsvm/svm.h

... (works fine) ...

$ cmake --build . --config Release
[  7%] Built target saga_api
[  7%] Linking CXX executable saga_cmd
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `stat64@GLIBC_2.33'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `fstat64@GLIBC_2.33'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `dladdr@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `dlclose@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `std::__exception_ptr::exception_ptr::_M_release()@CXXABI_1.3.13'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `dlerror@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_mutexattr_init@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_key_create@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_setspecific@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `std::__exception_ptr::exception_ptr::_M_addref()@CXXABI_1.3.13'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_mutex_timedlock@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_cancel@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_join@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_setname_np@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_mutex_trylock@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `lstat64@GLIBC_2.33'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `dlsym@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_setconcurrency@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_getspecific@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_attr_setstacksize@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_key_delete@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `dlopen@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_mutexattr_settype@GLIBC_2.34'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/libwx_baseu_unofficial-3.2.so: undefined reference to `pthread_create@GLIBC_2.34'
collect2: error: ld returned 1 exit status
make[2]: *** [src/saga_core/saga_cmd/CMakeFiles/saga_cmd.dir/build.make:130: src/saga_core/saga_cmd/saga_cmd] Fehler 1
make[1]: *** [CMakeFiles/Makefile2:2350: src/saga_core/saga_cmd/CMakeFiles/saga_cmd.dir/all] Fehler 2
make: *** [Makefile:130: all] Fehler 2

Here's some info about my system:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Zorin
Description:    Zorin OS 16.3
Release:    16
Codename:   focal

$ uname -a
Linux dell-zorin 5.15.0-91-generic #101~20.04.1-Ubuntu SMP Thu Nov 16 14:22:28 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

How can I install the latest SAGA version instead?

8
  • Have you tried using a more modern version of Ubuntu? It seems you're Ubuntu is technically four years old, so all the libraries that a modern saga needs aren't there. Jan 8 at 1:09
  • And installing Debian packages on a Ubuntu doesn't work, at all (not even sure this is Ubuntu, it seems to think it is called zorin) Jan 8 at 1:10
  • It would seem that if Ubuntu 24.04 was already released, that would contain saga 9.3.0. you could update to a more modern version of Ubuntu now to not have an annoying upgrade when it's actually released, and then use the fact that container stuff got better in the last four years to run saga in a podman Ubuntu24.04 beta container Jan 8 at 1:17
  • Your compilation errors look like you installed random versions of C libraries. Chances are you're breaking your system in subtle or not so subtle ways! Jan 8 at 1:18
  • Well, I sadly cannot install a different OS on my computer just because some geo project requires it 😕. I use Zorin OS 16 which is just a derivative of Ubuntu 20.04 LTS with mostly UI changes. Zorin 17, which is based on Ubuntu 22.04 LTS, is not yet available as an upgrade, just for fresh installations.
    – Pixelcode
    Jan 8 at 20:38

1 Answer 1

0

Recently, an upgrade from Zorin 16.3 to 17 was released, and now everything works as expected.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Zorin
Description:    Zorin OS 17
Release:    17
Codename:   jammy

$ uname -a
Linux dell-zorin 6.5.0-15-generic #15~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Jan 12 18:54:30 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .