0

I have a disk in the following state:

zpool status
  pool: data
 state: DEGRADED
  scan: resilvered 1.49G in 05:08:02 with 0 errors on Sat Jan  6 18:35:13 2024
config:

        NAME                                   STATE     READ WRITE CKSUM
        data                                   DEGRADED     0     0     0
          raidz2-0                             DEGRADED     0     0     0
            ata-ST8000VN0022-2EL112_ZA1G3L0J   ONLINE       0     0     0
            ata-ST8000VN0022-2EL112_ZA1GFZGP   ONLINE       0     0     0
            ata-ST8000VN0022-2EL112_ZA1G3BC0   ONLINE       0     0     0
            replacing-3                        UNAVAIL      0     0     0  insufficient replicas
              2422871744397392782              UNAVAIL      0     0     0  was /dev/disk/by-id/ata-ST8000VN0022-2EL112_ZA1G3A0E-part1
              ata-ST8000VN004-3CP101_WWZ3W4DB  FAULTED      3     0     0  too many errors
            ata-ST8000VN0022-2EL112_ZA1FMCMG   ONLINE       0     0     0

errors: No known data errors

The scan message is from the last drive, which got errors when I tried to replace #3. I've replaced that one, and now I'm trying to get #3 to retry and fix itself, but nothing works.

I've tried doing the same replace with force. I've tried onlining the replacement disk, I've tried clearing that disk and the entire pool. Nothing. It's just stuck there.

How do I get it to restart now?

1
  • 1
    99% of my ZFS experience is on FreeBSD, but I think the first thing to accomplish is to abort the rebuild. Try offlining the drive: zfs offline data /dev/.../ata-ST8000VN004-3CP101_WWZ3W4DB. See if you can get that accomplished, then edit your post to update your situation (zpool status and anything else relevant) and where you're stuck.
    – Jim L.
    Jan 8 at 4:43

1 Answer 1

0

I was able to get this working but offlining the drive that was to replace the old one, then forcing a resilvering on the drive it thought was damaged but wasn't.

Then I pulled the physical drive that I offlined and reinserted it. At this point it let me run the zpool replace command to restart the process and it finished successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .