1

I have a Dell, debian stable, laptop working with gnome environment. For several weeks Firefox crashed more and more often, resulting in mouse slows down during fews seconds, and then everything freezes, the laptop heats a lot, forcing me to hard reboot. I noticed that websites such as WhatsApp web or YouTube were specifically involved in the "crash situations".

For a week now, things have gotten much worse, any request on Google, with one window and one tab, crashes. I noticed that setting javascript.enabled=false in the settings of ff preserves from crashes. Also, signal-desktop segfaults when launched.

I have issues finding enlightening logs, but can try.

I also tried to uninstall and reinstall all the java packages but didn't have any effect.

I ran journalctl -f, then waited for firefox to crash and I have uploaded the resulting log here: https://pastebin.com/4hFgtyAj.

And, probably more readable, the logs corresponding to the segfault of signal-desktop: https://pastebin.com/9b4zd2Cm.

I am also running memtest and I already have more than 800 errors.

10
  • Javascript is not related to Java. Please run journalctl -f, execute Firefox and make it crash as you said then post what logs you got using the previous command.
    – td211
    Jan 6 at 14:13
  • I missed that question sorry. pastebin.com/4hFgtyAj Everything from the middle of line 1 to line 464 is colored in red, in my terminal
    – Boudy
    Jan 6 at 14:50
  • Probably more readable, the logs corresponding to the segfault of signal-desktop: pastebin.com/9b4zd2Cm
    – Boudy
    Jan 6 at 14:58
  • Do you have any modifications that would classify as "Franken Debian"? (as in mixing repos like testing and stable)
    – td211
    Jan 6 at 15:44
  • No, to my knowledge the worse I have is references to non-free(-firmware) in my apt sources.list
    – Boudy
    Jan 6 at 15:46

2 Answers 2

0

According to your comment, memtest is returning a large amount of errors.

This means that something related to your system memory is wrong, most likely your RAM module. You should replace your RAM module(s) if these are removable.

0

The problem was actually an outdated BIOS, upgrading it solved almost everything. Noticed that there was also something wrong with libxul.so, everything was fine after I deleted and reinstalled it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .