Last month I set up a Linux Mint install all my computer for development. The install was on its own partition on a HDD separate from my usual Windows boot.

Today I was working away for a couple hours when I started being unable to save any of my files due to a "Read only file system error" that looks exactly how this user describes.

My first instinct is of course to reboot. After selecting my Linux install from the boot menu I'm greeted with this message:

hid-generic 0003:1532:024E.0007: No inputs registered, leaving

enter image description here

That's as far as I get. I don't know how to figure out what is not being registered, but judging from the preceding issue it's probably the hard drive or something, which otherwise works fine from my Windows boot.

  • Yes, it's likely a fatal drive failure. The read-only state prior to the incident was the warning. Commented Jan 5 at 22:08
  • The drive is a year old, and appears to read and write perfectly fine on windows.
    – SpringsTea
    Commented Jan 6 at 2:02
  • Are Windows and Mint in the same drive? Commented Jan 6 at 2:16
  • 1
    The hid-generic error message refers to Human Interface Devices, not storage devices. The numbers suggest it might be about a Razer BlackWidow V3 gaming keyboard. Can you type in commands at that point? Try lsblk or cat /proc/partitions to find out which drives have been successfully detected.
    – telcoM
    Commented Jan 6 at 2:19
  • @telcoM cat /proc/partitions worked, but the results didn't really mean anything to me. I assumed it correctly listed all my partitions. I've resolved my issue and updated my question with what I did. Thanks for the help.
    – SpringsTea
    Commented Jan 10 at 21:30

1 Answer 1


On a whim I typed exit into the console on this boot screen. When I did that I got a message about my OS being corrupt and it recommended a command to run (I think it was fsck but I can't remember for sure).

I ran the command on the partition Linux is installed on, and it went through and repaired a bunch of blocks and inodes that were corrupt or missing and afterwards I was able to boot with no data lost.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .