1

In a fresh Arch Linux Installation with Gnome occurring display errors on specific applications.

I have reinstalled Arch Linux (archlinux-2024.01.01-x86_64.iso) due to display errors after an update using "pacman -Syu" on January 2, 2024. On Apps like Console, Nautilus:

  • The application window flickers.
  • In particular, the window-backgroundcolor is missing and the controls ("X" for close) are missing.
  • There are streaks when moving the window.

Unfortunately, the same display errors also occur in the fresh installation. With other applications, such as Gnome-Optimizations or Firefox, these display errors do not occur.

What I have done so far

Alternatively, I installed Arch Linux with Cinnamon and did not get these display errors. However, I would like to get Gnome working again.

System:

  • Notebook: Lenovo B560 (Family: IDEAPAD)
  • Processor: Pentium P6100, 2 GHz
  • RAM: 3 GB
  • Graphic: Intel integrated Graphic Controller, rev. 02
  • Kernel Driver in use: i915

Until this update attempt, this system worked flawlessly.

Does anyone have an idea how I can solve this problem?Until this update attempt, this system worked flawlessly

Best Regards

1
  • I have since installed an older version from September 2023 and it worked. When the system was updated, the display errors described above occurred in certain windows. I could well imagine that it could possibly be a problem with OpenGL/Vulkan, as the laptop is already very old (year of manufacture ~ 2010).
    – JD38292
    Commented Jan 6 at 22:32

1 Answer 1

2

Solution : The mesa driver is usually installed during the standard installation of Arch Linux. That was probably the problem.

Apparently, the older Intel graphics cards are no longer supported with regard to (OpenGL/Vulkan). In this article it is pointed out that in this case (old graphics card) the "mesa-amber" driver should be installed instead of the "mesa" driver. On the same page, the "vulkan-intel" package is recommended for Vulkan support.

When installing "mesa-amber", "mesa" was uninstalled because otherwise they would conflict. The installation of the "vulkan-intel" package went smoothly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .