1

I have unsuccessfully tried to format and mount a 64 G USB flash drive. The error when I try to mount with the command mount -t extfs /dev/sda /mnt

**"JBD: no valid journal superblock found
EXT4-fs (sda1): error loading journal"**

I am wondering if this is due to the large size of the USB disk. This is a new disk and was working well with Windows NTFS system. I deleted the partition and then tried to use it with centos but it does not work I followed the instructions on Formatting USB drive on Linux

   1. fdisk -l says /dev/sda
   2. partition gets created properly with fdisk /dev/sda. 
   3. I did n and then chose primary partition 
   4. I also did p to print and also did v to verify the partition table. 
   5. I did w to write the partition. 
   6. I did mkfs.ext4 /dev/sda1 . And it does not show any problems

Output for fdisk /dev/sda

*"Command (m for help): n
Command action
   e   extended
   p   primary partition (1-4)
p
Partition number (1-4): 1
First cylinder (1-64000, default 1): 
Using default value 1
Last cylinder, +cylinders or +size{K,M,G} (1-64000, default 64000): 
Using default value 64000
Command (m for help): p
Disk /dev/sda: 67.1 GB, 67108864000 bytes
64 heads, 32 sectors/track, 64000 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2fea756a
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       64000    65535984   83  Linux
"*

Output of mkfs.ext4

*"[root@rverma ~]# mkfs.ext4  /dev/sdc1
mke2fs 1.41.12 (17-May-2010)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
4096000 inodes, 16383996 blocks
819199 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=4294967296
500 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
    4096000, 7962624, 11239424
Writing inode tables: done                            
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done
This filesystem will be automatically checked every 27 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override."*
  • Seems like you were able to format it. Was there a problem mounting? – phunehehe May 21 '13 at 16:27
  • The above output looks fine. How did you try and mount it. mount /dev/sdc1 /mnt for starters should work. What errors do you get when you try and mount using my command? – slm May 21 '13 at 21:33
  • Thanks for response. Yes I was able to response. Sorry I was not clear about the error. I have edited the original question accordingly as mentioned below "The error when I try to mount with the command mount -t extfs /dev/sda /mnt "JBD: no valid journal superblock found EXT4-fs (sda1): error loading journal"" – doon May 22 '13 at 10:29
  • There's a bit of confusion between /dev/sda (mount command), /dev/sda1 (fdisk) and /dev/sdc1 (mkfs). Can you clarify that in your question? – Flup May 22 '13 at 10:40
  • Try to leave the '-t extfs' part out and see the results. – schaiba May 22 '13 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.