0

I've got a problem. I cannot install any OS and I don't know why. I as usually copied artix linux iso to my flash drive to install it on server. Then in BIOS settings, drive didn't appear till I changed boot type to legacy. But when I try to boot from disk I got message that I have no bootable device. I tried to do the same with Manjaro, mark the volume as bootable, take another usb drive, even tried to boot from laptop, but nothing gave me effect. I had a problem with proxmox before, I don't know if it the same, but the kernel didn't load up on server, so I booted proxmox on laptop and installed it on hard drive via usb adapter, but now I am not able to do even that. Also, I have artix installed on my laptop, but somehow it doesn't detect any usb bootable drives in BIOS like before, only as external storage. P. S. Sorry for my bad english, I tried my best:)

4
  • can you tell us what it means to "copy artix linux iso to my flash drive"? Because, usually, that's not how you make bootable USB drives, assuming you just copied the .iso file onto the stick's file system. Jan 2 at 20:58
  • I meant writing image via dd to volume, like "dd if=some.iso of=/dev/sdaX"
    – username
    Jan 2 at 22:25
  • Well, it was very stupid, it turns out that I misunderstood the work of this program and in principle what iso images are, so I forgot that it is necessary to specify the whole disk and not the partition. Thank you!
    – username
    Jan 2 at 22:45
  • ironically, copying the iso to the filesystem on the usb works fine if you first install ventoy.
    – user10489
    Jan 2 at 23:09

1 Answer 1

0

I should specify not the partition, but the whole disk

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .