0

I am following the instructions on how to install LibreOffice on Fedora which is what I believe Amazon Linux 2023 uses under the hood:

https://tecadmin.net/install-libreoffice-on-fedora/

I can download and extract the zip package. However, when I run dnf install RPMS/*.rpm, I get the following error:

error: No package matches 'RPMS/libobasis7.6-base-7.6.4.1-1.x86_64.rpm'

The content of the RPMS folder is as follows:

-rw-rw-r-- 1 root root  1237800 Dec  1 10:51 libobasis7.6-base-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  7643097 Dec  1 10:51 libobasis7.6-calc-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root 91309240 Dec  1 10:54 libobasis7.6-core-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     6407 Dec  1 10:52 libobasis7.6-draw-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root    81581 Dec  1 10:52 libobasis7.6-en-US-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   404419 Dec  1 10:51 libobasis7.6-extension-beanshell-script-provider-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   642636 Dec  1 10:51 libobasis7.6-extension-javascript-script-provider-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  1998248 Dec  1 10:52 libobasis7.6-extension-mediawiki-publisher-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  1067433 Dec  1 10:52 libobasis7.6-extension-nlpsolver-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  3329870 Dec  1 10:51 libobasis7.6-extension-pdf-import-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  2971346 Dec  1 10:52 libobasis7.6-extension-report-builder-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  2959808 Dec  1 10:52 libobasis7.6-firebird-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   610717 Dec  1 10:54 libobasis7.6-gnome-integration-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  1222506 Dec  1 10:51 libobasis7.6-graphicfilter-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root 61644927 Dec  1 10:51 libobasis7.6-images-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   191522 Dec  1 10:51 libobasis7.6-impress-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  2340064 Dec  1 10:51 libobasis7.6-kde-integration-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   208326 Dec  1 10:51 libobasis7.6-librelogo-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     3718 Dec  1 10:51 libobasis7.6-libreofficekit-data-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   538291 Dec  1 10:51 libobasis7.6-math-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   157039 Dec  1 10:52 libobasis7.6-ogltrans-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   125283 Dec  1 10:51 libobasis7.6-onlineupdate-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root 17292382 Dec  1 10:51 libobasis7.6-ooofonts-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     2757 Dec  1 10:51 libobasis7.6-ooolinguistic-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  2025230 Dec  1 10:51 libobasis7.6-postgresql-sdbc-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root    13292 Dec  1 10:51 libobasis7.6-python-script-provider-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  9795742 Dec  1 10:51 libobasis7.6-pyuno-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  3952315 Dec  1 10:51 libobasis7.6-writer-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   420612 Dec  1 10:51 libobasis7.6-xsltfilter-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   576247 Dec  1 10:52 libreoffice7.6-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     2347 Dec  1 10:51 libreoffice7.6-base-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     2343 Dec  1 10:51 libreoffice7.6-calc-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  5682300 Dec  1 10:51 libreoffice7.6-dict-en-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  2780003 Dec  1 10:51 libreoffice7.6-dict-es-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root  1857501 Dec  1 10:51 libreoffice7.6-dict-fr-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     2347 Dec  1 10:51 libreoffice7.6-draw-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     7518 Dec  1 10:52 libreoffice7.6-en-US-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root   752859 Dec  1 09:09 libreoffice7.6-freedesktop-menus-7.6.4-1.noarch.rpm
-rw-rw-r-- 1 root root     2382 Dec  1 10:54 libreoffice7.6-impress-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     2347 Dec  1 10:52 libreoffice7.6-math-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root 14441942 Dec  1 10:52 libreoffice7.6-ure-7.6.4.1-1.x86_64.rpm
-rw-rw-r-- 1 root root     2369 Dec  1 10:54 libreoffice7.6-writer-7.6.4.1-1.x86_64.rpm

It appears that the missing file is actually there, but I can't install LibreOffice.

This is my dockerfile, and I am executing this on an Apple M3 Macbook:

FROM --platform=linux/amd64 public.ecr.aws/lambda/python:3.12

RUN dnf install \
    gzip \
    wget \
    tar \
    -y && \
    dnf clean all

RUN wget https://download.documentfoundation.org/libreoffice/stable/7.6.4/rpm/x86_64/LibreOffice_7.6.4_Linux_x86-64_rpm.tar.gz
RUN tar -xvf LibreOffice_7.6.4_Linux_x86-64_rpm.tar.gz
RUN cd LibreOffice_7.6.4.1_Linux_x86-64_rpm/
RUN dnf install RPMS/*.rpm
2
  • Try adding -v (for more verbose output).
    – Allen
    Dec 26, 2023 at 20:44
  • @Allen this is not a valid command dnf install *.rpm -v -y. How do I add more verbose output?
    – kravb
    May 22 at 20:29

1 Answer 1

1

More information such as the commands you are running and the full error you get from those commands would be helpful. Though I think I know what your problem may be.

Each RUN command in a Dockerfile is a different shell session, so your cd would not carry into the next session and you would be placed back into the working directory.

Try combining the two commands into one RUN statement:

RUN cd LibreOffice_7.6.4.1_Linux_x86-64_rpm/ && dnf install RPMS/*.rpm

or don't use cd at all:

RUN dnf install LibreOffice_7.6.4.1_Linux_x86-64_rpm/RPMS/*.rpm
1
  • Lets assume it is not a working directory issue. I have connected to the container and cd into the RPMS directory. I can confirm that all rpm files are there. Then when I run dnf install *.rpm -y , I can the following error: error: No package matches 'libobasis7.4-base-7.4.4.2-2.x86_64.rpm' Taking Dockerfile out of thee equation and assuming the file is present and I am in the correct directory, why would I still get the error?
    – kravb
    May 22 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .