2

After an update/ upgrade on Debian 12 (weekly update), there is NO WiFi, files are not opening, unable to shutdown or sleep, and freezes when using sudo. The bug is fixed with a new release of kernel. But, I am NOT able to install the new kernel.

  1. I downloaded the new kernel file to a flash drive using another laptop
  2. Copied it to the freezing laptop
  3. But on hitting the command:
$ sudo apt install ./linux-image-6.1.0-16-amd64_6.1.67-1_amd64.deb

terminal freezes without prompting for password.

EDIT:

Tried to edit

$ nano /etc/default/grub
# GRUB_DEFAULT=0 
GRUB_DEFAULT="1>2"

But it could not be saved since I did NOT use 'sudo'. But, when I use sudo

$ sudo nano /etc/default/grub

It freezes without prompting for password (may be because of Network Manager issue)

Any help?

0

2 Answers 2

1

I got the trick from @Jaromanda X and details from u/Hendersen43 and

u/Only_Space7088 at:

https://www.reddit.com/r/debian/comments/18i60wx/networkmanager_service_freezes_the_whole_pc_after/

I am giving details to help newbees...:

I solved it by:

(1) Interrupting booting process, and changing the kernel back to the previous version:

While booting, press F9 to interrupt the booting

Then, use arrow keys on keyboard to highlight the previous kernel version and press ENTER

(2) Download the patched kernel (linux-image) from the site (from the above reddit posting):

https://ftp.debian.org/debian/pool/main/l/linux-signed-amd64/linux-image-6.1.0-16-amd64_6.1.67-1_amd64.deb

(3) Change Directory to Downloads folder (where the image is downloaded)

(4) Installing it using the command (from the above reddit posting):

me@debian~/Downloads$ sudo apt install ./linux-image-6.1.0-16-amd64_6.1.67-1_amd64.deb

(5) Updating and then upgrading to the matching headers (linux-headers)

$ sudo apt update

$ sudo apt upgrade

EDIT: I was unable to make changes in any system file nor install/ remove kernel, because on hitting 'sudo' the system hangs without prompting for password.

@GAD3R: Thank you for your detailed answer. But I was unable to make any change in any file or install anything since 'sudo' was disabled. @garethTheRed: thank you

0

If installing a new kernel solve your problem, You should install a new linux-image from Debian backports, it is easy, fast and secure.

Switch back to an older kernel.

Undo any changes in your grub configuration file.

Adding backports:

echo "deb http://deb.debian.org/debian bookworm-backports main contrib non-free" |
sudo tee -a /etc/apt/sources.list
sudo apt update
sudo apt-get install -t bookworm-backports linux-image-amd64

Backports instructions.

Backports on Debian Wiki.

2
  • Thank you for your support. But, my problem was the moment I hit 'sudo' , it hangs before prompting for password.
    – A. John
    Dec 17, 2023 at 0:11
  • @A.John check your /etc/hosts file if correctly set or not. Then disable iwd service and wpa_supplicant service.
    – GAD3R
    Dec 17, 2023 at 0:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .