0

When I'm using my laptop if I don't use it for a while, the laptop's screen goes off and the external monitor turns off by itself. I'm trying to prevent my second monitor from turning off, and I want it to remain a blank black screen for a given period of time when the system passes to an idle state.

I'm connecting a second screen to my laptop by an HDMI cable to an LCD screen. I use Debian 12 (bookworm), and I use gnome-43.9 desktop environment. I also use the Wayland windowing system.

I tried xset s off and it didn't effect anything. There was no error when executing this command.

When I tried xset -dpms I got this error message: server does not have extension for -dpms option

I looked up similar questions and other Stack Exchange forums, but I couldn't find a way to get around this problem.

1 Answer 1

0

Ok, so first of all, the reason that xset doesn't do anything is because it's an command only for x11.

Secondly, on wayland your compositor is the one that controls your screen, so you want to look at your compositor for that. You said you're on GNOME, so that means you have to edit your GDM config.
The way to disable your monitor turning off on idle with GDM is to edit /etc/gdm3/greeter.dconf-defaults and add this to it:

# Automatic suspend
# =================
[org/gnome/settings-daemon/plugins/power]
# - Time inactive in seconds before suspending with AC power
#   1200=20 minutes, 0=never
sleep-inactive-ac-timeout=0
# - What to do after sleep-inactive-ac-timeout
#   'blank', 'suspend', 'shutdown', 'hibernate', 'interactive' or 'nothing'
# sleep-inactive-ac-type='suspend'
sleep-inactive-ac-type='nothing'
# - As above but when on battery
# sleep-inactive-battery-timeout=1200
# sleep-inactive-battery-type='suspend'
1
  • Thanks for your help. I've done as following sleep-inactive-ac-timeout=4500 and sleep-inactive-ac-type='nothing' and restarted the OS but it didn't have any affect. Screen again turns off as it was.
    – livan3li
    Dec 13, 2023 at 11:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .