11

I have a sports-watch which has an integrated flash-memory. This flash-memory is used to store training information. When I connect the watch to my computer using the USB cable, it's detected as write-protected flash drive:

[354703.052138] sd 7:0:0:0: [sdc] Write Protect is on

..and I obviously can't remount the partition with RW rights:

root@T60:~# mount -vt vfat -o rw,remount /dev/sdc1 /media/
mount: cannot remount block device /dev/sdc1 read-write, is write-protected
root@T60:~# 

I remembered that hdparm had an option to change the readonly flag for a device and as USB flash-drive is detected as an SATA drive, then I gave it a try, but this did not help either:

root@T60:~# hdparm -r0 /dev/sdc

/dev/sdc:
 setting readonly to 0 (off)
 readonly      =  0 (off)
root@T60:~# mount -vt vfat -o rw,remount /dev/sdc1 /media/
mount: cannot remount block device /dev/sdc1 read-write, is write-protected
root@T60:~# 

I guess that the watch is designed in a way that once it detects the USB connection, it triggers the (hardware) USB write-protection switch? Is such hardware write-protection part of the USB standard? Or is there something left to try?

1

I realize this is a Unix & Linux site but if you have access to a PC I'd try out some of the tips from this site:

There is a tool listed on that site called RMPrepUSB, which has worked in past as well, YMMV. Here's a screenshot of that tool:

    ss of RMPrepUSB

I've run into issues with MP3 players becoming read only, and the only fix I could find was to mount them on a PC and either use one of the tips suggested in that post or to right click on the device in Windows Explorer, and uncheck the "Read Only" attribute.

You might be able to confirm that this attribute is the root cause and use mtools or mattrib to uncheck this under Linux as well.

Update the firmware?

From the Timex user's manual:

GET THE LATEST FIRMWARE

While you can use the watch right out of the box, the online firmware will have the latest enhancements and improvements. Use the Device Agent to connect the watch to your computer and get the latest updates.

  1. Download the Timex® Device Agent for USB Devices at: http://TimexIronman.com/DeviceAgent

  2. Connect the charging clip to the watch, then plug the USB cable into the computer. A picture of a connected computer appears on the watch display.

  3. Open the Device Agent on your computer.

  4. If prompted by the Device Agent, follow the onscreen instructions to download the latest watch firmware.

References

  • I tried to remove the write protection of the flash drive with RMPrepUSB utility under Windows 8, but this did not work. Flash-memory is still detected as [442499.462150] sd 7:0:0:0: [sdb] Write Protect is on. I guess it's write-protected either in firmware or in flash-memory controller. However, I'm still bit puzzled how can firmware or memory controller determine that file-system is write-protected? By not allowing any write operations and sending a certain USB signal which tells to OS that drive is write-protected? – Martin Oct 31 '13 at 21:35
  • 1
    @Martin - What is the model of this watch? It would seem to be something with the watch specifically. – slm Nov 1 '13 at 1:03
  • It's TIMEX Run Trainer 2.0. I'm fairly sure that the write-protection is implemented in memory controller or firmware or the watch and it's not just an indication to operating-system not to write data to drive as it has been the case with SD cards. – Martin Nov 2 '13 at 1:19
  • @Martin - based on the behavior I'd be inclined to agree. – slm Nov 2 '13 at 1:22
  • @Martin - this is the watch right? dcrainmaker.com/2013/03/trainer-depth-review.html – slm Nov 2 '13 at 1:27

protected by Community Nov 30 '15 at 16:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.