0

Hi the other day I tried to update my packages, but I ran into some issues: using "dnf update" I get following Error: Error: Problem: conflicting requests (try to add '--skip-broken' to skip uninstallable packages) (after using the recommendet flag I just get the same error) this seems to be a problem many people struggle with, but none of the solutions I found worked for me.

I also tried following command: "dnf install kernel-core"

Package kernel-core-6.2.9-300.fc38.x86_64 is already installed. Package kernel-core-6.5.9-200.fc38.x86_64 is already installed. Package kernel-core-6.5.10-200.fc38.x86_64 is already installed. Package kernel-core-6.5.11-300.fc39.x86_64 is already installed. Dependencies resolved.

Problem 1: package kernel-modules-extra-6.5.10-200.fc38.x86_64 from @System requires kernel-uname-r = 6.5.10-200.fc38.x86_64, but none of the providers can be installed

  • conflicting requests Problem 2: package kernel-6.5.10-200.fc38.x86_64 from @System requires kernel-core-uname-r = 6.5.10-200.fc38.x86_64, but none of the providers can be installed
  • conflicting requests Problem 3: package kernel-modules-6.5.10-200.fc38.x86_64 from @System requires kernel-modules-core-uname-r = 6.5.10-200.fc38.x86_64, but none of the providers can be installed
  • conflicting requests Nothing to do. Complete!

I'm quite stuck at the moment, I would greatly appreciate if someone would help me :)

3
  • You have both Fedora 38 and 39 kernel packages installed kernel-6.5.10-200.fc38.x86_64 and kernel-core-6.5.11-300.fc39.x86_64. The conflicts look to be from the Fedora 38 kernels. If you are running on the Fedora 39 kernel (6.5.11, check with uname -r), check to make sure your upgrade process worked properly to completion, then remove the Fedora 38 kernels (and possibly any leftover f38 packages) to see if that fixes your issues. Dec 12, 2023 at 16:55
  • Hi thanks for your helpful reply :) I am currently running following version of the kernel 6.2.9-300.fc38.x86_64 How do I ensure that the new kernel is properly implementet? Dec 12, 2023 at 22:48
  • That is another Fedora 38 kernel. It looks like you tried to upgrade Fedora 38 to 39. Did the upgrade succeed? If the upgrade did succeed, have you rebooted into the new kernel? If you cannot boot into the new kernel, that would indicate issues that would require more information to troubleshoot. Dec 13, 2023 at 7:22

2 Answers 2

0

Not sure how common it is but I had the same issue, seems like something isn't right with the update process from Fedora 38 to 39 but the fix is easy.

Run uname -r to check your kernel version, if it's 6.2.9 like for me and the author of this thread you just have to boot into Grub (hold Shift during boot), select the latest available Kernel and boot with that, afterwards dnf update should work again!

1
  • Thank you!! This fixed my issue. I nearly reinstalled my hole system :) Jan 30 at 18:16
0

Just came across this problem and found the error message a bit misleading. When it says @System requires kernel-uname-r = 6.5.10-200.fc38.x86_64 it sounds like it's looking for another package named "kernel-uname-r" but it isn't.

What it wants is to run uname -r and get "6.5.10-200.fc38.x86_64" as a response, but the error indicates that it isn't. In my case, this meant "you've kept up with all your updates but you haven't rebooted in 3 years so the running kernel is way out of date."

So when coming across this error, try rebooting the system and run the update command again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .