4

I've installed FreeBSD 9.1 in a VirtualBox VM, and did some basic setup.

After that, I had installed Gnome2 via sudo pkg_add -r gnome2.

Along the way, there were some errors. Mostly it was (I think) the package manager complaining about dependencies. They were piling up faster then they were getting resolved (sometimes a package that was reported as a broken dependency would get installed), and when there was around a dozen of them, the installation had stopped without any errors.

I had simply executed the command again, waited for 20 more minutes, and then got greeted with an "installation successful" message.

I restarted the system only to end up with GDM not starting and a regular text prompt ready.

In trying to solve this I had:

  1. added gnome_enable="YES" to /etc/rc.conf (Why wasn't it there by default?)
  2. added proc /proc procfs rw 0 0 to /etc/fstab (I'm not even sure how this is related, but it was supposed to help... I suppose Gnome2 checks fstab for something.)

But I still have no luck, and GDM still doesn't show itself.

However, RC (rc.conf, or whatever is executing it) does report that it is starting GDM:

enter image description here

When I tried to execute /usr/local/etc/rc.d/gdm start, it displayed this error message and supposedly failed:

enter image description here

What should I do to start a Gnome2 graphical session in FreeBSD? How can I check whether I have everything I need installed and configured correctly?

3

I have fixed the issue.

Immediately after typing out that question, I thought it might be an X problem - and it seems that it was.

The problem was that xorg apparently hadn't been installed.

I ran sudo pkg_add -r xorg, and now each time I boot, Gnome2 is started and everything seems to work.

However, I still don't understand why "working" isn't the default behavior!

  • Beause it wouldn't be a FreeBSD installation. Sometimes i think this can only be so ancient and buggy because it is an intended educational punch in the face to learn how to google and RTFM. By the way, in the lastest 11 Beta 3 it is still the same problem. – Lothar Aug 2 '16 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.