0

I want to update kernel on AlmaLinux 8.9 because cifs is not working and it complains about OS version.

mount.cifs [...]
mount error: cifs filesystem not supported by the system

Current kernel seems to be 4.x

uname -r
4.18.0

After many attempts with yum (I am not familiar with dnf command) I was supposed to have installed newer kernel from elrepo:

yum install http://mirrors.nav.ro/elrepo/kernel/el8/x86_64/RPMS/kernel-lt-5.4.262-1.el8.elrepo.x86_64.rpm

# and later tried:

yum install http://mirrors.nav.ro/elrepo/kernel/el8/x86_64/RPMS/kernel-ml-6.6.4-1.el8.elrepo.x86_64.rpm

But after rebooting, uname -r still shows 4.x

yum list installed | grep kernel

elrepo-release.noarch               8.3-1.el8.elrepo                             @elrepo-kernel
kernel-lt.x86_64                    5.4.262-1.el8.elrepo                         @elrepo-kernel
kernel-lt-core.x86_64               5.4.262-1.el8.elrepo                         @elrepo-kernel
kernel-lt-modules.x86_64            5.4.262-1.el8.elrepo                         @elrepo-kernel
kernel-ml.x86_64                    6.6.4-1.el8.elrepo                           @@commandline
kernel-ml-core.x86_64               6.6.4-1.el8.elrepo                           @elrepo-kernel
kernel-ml-modules.x86_64            6.6.4-1.el8.elrepo                           @elrepo-kernel

In the above yum install list I also had a default kernel from OS (kernel.x86_64, kernel-core.x86_64, kernel-tools.x86_64) that shown 4.x next to them, I removed these and tried reinstalling 5.x and 6.x, still shows 4.x after reboot.

  • Maybe more kernels are installed now and I need to edit some grub file to select which kernel to use at boot ?
  • I cannot find any grub config files on this OS. find /etc -name *grub* returns nothing.
  • The df -h also shows no /boot. Edit: ok it is under /.
  • the /etc/fstab is empty, indicates strange config ?!
  • This is a virtual server from sketchy ISP, maybe kernel is somehow limited from parent OS ?

What else can I try ?

edit: Maybe this is relevant, what I could find in /var/log/messages:

cat /var/log/messages | grep -i '4\.18'
Dec  8 01:39:48 rev1g dracut[2705]: Executing: /usr/bin/dracut -f /boot/2ad75f1a643642c394a731eccfb1c125/4.18.0-513.9.1.el8_9.x86_64/initrd 4.18.0-513.9.1.el8_9.x86_64
Dec  8 01:39:52 rev1g dracut[2705]: *** Creating image file '/boot/2ad75f1a643642c394a731eccfb1c125/4.18.0-513.9.1.el8_9.x86_64/initrd' ***
Dec  8 01:39:56 rev1g dracut[2705]: *** Creating initramfs image file '/boot/2ad75f1a643642c394a731eccfb1c125/4.18.0-513.9.1.el8_9.x86_64/initrd' done ***
[root@rev1g log]#
[root@rev1g log]#
[root@rev1g log]# cat /var/log/messages | grep -i '5\.4'
Dec  8 05:12:39 rev1g dracut[4399]: Executing: /usr/bin/dracut -f /boot/2ad75f1a643642c394a731eccfb1c125/5.4.262-1.el8.elrepo.x86_64/initrd 5.4.262-1.el8.elrepo.x86_64
Dec  8 05:12:44 rev1g dracut[4399]: *** Creating image file '/boot/2ad75f1a643642c394a731eccfb1c125/5.4.262-1.el8.elrepo.x86_64/initrd' ***
Dec  8 05:12:48 rev1g dracut[4399]: *** Creating initramfs image file '/boot/2ad75f1a643642c394a731eccfb1c125/5.4.262-1.el8.elrepo.x86_64/initrd' done ***
[root@rev1g log]#
[root@rev1g log]#
[root@rev1g log]# cat /var/log/messages | grep -i '6\.6'
Dec  8 05:49:13 rev1g dracut[613]: Executing: /usr/bin/dracut -f /boot/2ad75f1a643642c394a731eccfb1c125/6.6.4-1.el8.elrepo.x86_64/initrd 6.6.4-1.el8.elrepo.x86_64
Dec  8 05:49:19 rev1g dracut[613]: *** Creating image file '/boot/2ad75f1a643642c394a731eccfb1c125/6.6.4-1.el8.elrepo.x86_64/initrd' ***
Dec  8 05:49:22 rev1g dracut[613]: *** Creating initramfs image file '/boot/2ad75f1a643642c394a731eccfb1c125/6.6.4-1.el8.elrepo.x86_64/initrd' done ***

I found more related files in /boot

ls -lha /boot/loader/entries
total 16K
drwxr-xr-x 2 root root 4.0K Dec  8 05:49 .
drwxr-xr-x 3 root root 4.0K Dec  8 01:39 ..
-rw-r--r-- 1 root root  303 Dec  8 05:12 2ad75f1a643642c394a731eccfb1c125-5.4.262-1.el8.elrepo.x86_64.conf
-rw-r--r-- 1 root root  297 Dec  8 05:49 2ad75f1a643642c394a731eccfb1c125-6.6.4-1.el8.elrepo.x86_64.conf

1 Answer 1

0

It turns out that this is because of different kind of virtualisaton, on some you can update kernel, on others you can't :/

Maybe someone can post more details, I used many VPS from many providers and I didn't run into this before, but maybe other providers always deliveres VPSs with updated kernels by default.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .