0

I have installed FreeCAD v0.18 successfully but when tried to upgrade using apt it was failed. I want to install v0.19 or higher but looks like latest version of FreeCAD is not listed in Apt repo so what is the best way to do it?

Also, while upgrading looks like VNC service also broken and not I am not able to connect through VNC server.

Starting applications specified in /etc/X11/Xvnc-session has failed.

I have checked everything on the server and was able to restore the VNC service but if I am trying to connect externally then it's not working but I am able to connect to localhost.

Any idea or suggestions ?

1
  • Please edit your question and tell us how you checked he available versions. I see version 0.20.2 is available for Debian, so how exactly did it fail when you tried to install it? What error did you get?
    – terdon
    Dec 6, 2023 at 9:37

1 Answer 1

0

To install FreeCAD v19 and higher, you have 2 solutions:

  1. Installing freecad v21.1 or the development release freecad-realthunder from snap store:

    sudo apt install snapd sudo snap install core sudo snap install freecad

or the beta:

sudo snap install freecad-realthunder
  1. Upgrade your Debian distribution from Buster to Bullseye FreeCAD v19 is available, or upgrade to Bookworm v20 is available.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .