0

Building has a annual power shutdown for maintenance for 2 days.

As such, prior to it, I have shut down the CentOS 6 server.

After the power is back on (2 days later), when I boot back up, I encountered the following image :

Kernel panic - not syncing: Attempted to kill int

I've Googled search around, and the most common answer is to disable SELinux during the boot. I have tried that - and it didnt helped (which made sense since I didn't touched SELinux).

Also, at the GRUB page, I tried booting into other kernel, 2.6.32-358.el6.x86_64 kernel - however, it encountered the same kernel panic.

I'm unsure if its due to hardware issues like disk failing, RAMs etc, or other issues

Update 1 :

  • I removed rghb and quiet parameters when booting the kernel, and there are more logs, specifically saying that lv_root and lv_swap could not be found.

  • Tried using rescue USB thumbdrive. However after selecting “Rescued installed system”, it has problem locating the system partition. Even explicitly stating the disk that contains the system, it has error.

  • Tried using live DVD as thumbdrive instead. In the live environment, mounting /dev/sda gives me error stating wrong file system : isw_raid_member. I believe it’s because my OS disk is configured as raid1(mirror) using mdadm. Googling around and I discovered dmraid -ay, which seems to sync /dev/sda and /dev/sdb as a volume. However, when I tried to mount the volume, it keeps saying that it is already mounted or the mount folder is busy.

At this point, I’m not sure what to do. My main priority is to retrieve the files instead

1
  • After using mdadm or dmraid -ay, the individual disks that are part of the RAID set will be exclusively locked by the RAID subsystem, and a new /dev/mapper/<something> device node should have appeared for accessing the contents. (With isw_, the <something> is probably something like isw_<alphabet soup>.) But since LVM is also there, pvscan and then vgchange -ay to explicitly activate the volume group (or display error messages if there is a problem) should be the way forward.
    – telcoM
    Commented Dec 4, 2023 at 22:02

2 Answers 2

1

specifically saying that lv_root and lv_swap could not be found.

that is a pretty good indication of the storage being used as root file system not being available, be it through data corruption, failed storage hardware…

it has problem locating the system partition

… heavy data corruption or failed storage device

My main priority is to retrieve the files instead

well, from the regular backup you've been running on a legacy server (,right?)!

mounting /dev/sda gives me error stating wrong file system : isw_raid_member

Please don't run potentially modifying operations on the last copy of your fresh data; chances are high you're doing something you'll regret later. You'll want to use your live USB environment to take an image of these disks to a separate medium or network storage, and then work on these images.

You don't need to mount a full disk, you'll want LVM to scan for physical volumes (pvscan), and then recover the files from volumes that can be restored.

0

Thanks to the above comments - using dmraid -ay, and a combination of commands like pvscan, vgscan, lvscan (which scans all the existing volumes/partitions) and subsequently doing vgchange -ay and lvchange -ay, I was able to mount my root and home partitions and backup the data.

After backing up the data, I continued to fiddle with the system. I tried changing my SATA configuration from AHCI to RAID. But, that doesn't solve the issue. However, when I go to last section of the BIOS, where there's a Boot override section, I saw there's a Intel Volume0. Selecting Intel Volume0, I was able to boot back the system into CentO - strange.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .