5

I just installed CentOS 6.4 on an old machine I acquired for a development box, but I am running into keyboard issues I can't get around.

I start the machine and go to type a user name in and whatever key I press first just starts repeating forever. I have tried pressing different keys to get it to stop it but even unplugging the keyboard doesn't stop it repeating.

Honestly just want to get in there and set up SSH / SVN and I will probably never log in locally again, but I can't get in to do that at all right now.

I have even tried plugging the keyboard into other ports and various other things like that, but I have not managed to figure out what the problem is. I know the keyboard works fine because I used it during the install to type in the url for net install and the account information. I am even typing on it right now to ask this question.

Is there something I am missing here? Should I just try a reinstall? Or get a different keyboard?

  • I've never ran into this problem on Centos. Never even heard of it. Sounds like a key bounce problem with the keyboard, though. Other OS's might be catching the bounce or something if it works elsewhere. – Bratchley May 18 '13 at 18:17
  • Possibly, but I would think that would only cause a single extra letter. This issue continues to repeat the key infinitely, even after the keyboard is unplugged. – eseglem May 18 '13 at 18:43
  • 2
    It might still be the keyboard, the keyboard is also supposed to notify the OS via IRQ interrupt when a key is released. So it's possible that it's just that is the specific part of the keyboard and/or system that is broken. If you boot from a live fedora disc do you get the same issue (like if you try to type something into the terminal)? – Bratchley May 18 '13 at 18:47
  • What type of keyboard is this BTW? – Bratchley May 18 '13 at 18:53
  • Like I said in the initial post, the keyboard had no issues while running the install. So setting the root password and typing in the url for net install were not an issue. I figured that the install would have the same drivers as the end system, so wouldn't be a problem. The keyboard is a Razer, Black Widow Ultimate, maybe 8 months old. I Think I will have to just download the full iso's instead of doing net install and try different again to see if something went wrong on the install. – eseglem May 18 '13 at 22:54
0

I kept having almost this same issue (sort of) when I would access my Centos 6 VM through Windows RDP or VNC. I noticed that my issue appeared to be a Windows-like "Sticky Key" where I would start typing something either in the vim editor or in my IDE (Intellij IDEA) and all the sudden the last letter I typed would just "take off". For example, I could be typing "int newInt" and after the 't' in 'newInt' the editor would do something like "newInttttttttttttt.." until I hit the 'Esc' key or 'Ctrl+c' to stop it. VERY ANNOYING!

I started looking around and I was surprised to not find any one else having this same issue.. I thought maybe I was searching incorrectly because, after all, this is a strange bug to try and search for. Some suggest hitting ctrl+Shift simultaneously to disable - but that seems to be for Windows Sticky Keys only, but I haven't noticed it happening since I did that. So try that first. Then (If you have gnome/GUI desktop) enabled, go to System->Preferences->Keyboard and turn off / uncheck "Repeat Keys" under the "General" tab. I'm not sure which of those two did the trick for me, but I haven't had an issue since I did that.

0

Look at kbdrate - it fixed the same problem with me.

  • one-line answers are often not that helpful. Consider expanding your post with links, documentation or other elaboration supporting your suggestion. – HalosGhost Sep 17 '14 at 3:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.