0

Update: Solved! See the bottom for what I did.

To use a university's VPN, I tried to install the official GlobalProtect client for linux (I'm using Fedora, so I followed the Red Hat instructions). It kept crashing and didn't work, so I found an open source alternative that works fabulously. Now, I wanted to delete the official client.

The official instructions for removing it didn't include instructions for Red Hat / Fedora, so I tried to manually find all the files I downloaded or the installer created and delete them.

This mostly worked. The app no longer shows up in Application Launcher on KDE Plasma, and the command to start the CLI version isn't recognized. But every time I log in, the first thing I see is a pop up to use the GUI for the official GlobalProtect client. It looks slightly different from the open source one, so I know it's the one I tried to delete. It also creates a folder .GlobalProtect in my Home directory.

I tried deleting the .GlobalProtect folder, but it reappeared when I rebooted.

How can I get rid of this? I can live with the hidden file in my Home directory, but I'd really like to not see the app GUI every time I reboot. What might be triggering the launch? I couldn't find anything in my .bashrc file, which is the only place I know to look for things that happen on login.

(Please let me know if there's a better set of tags to use, I'm unsure.)

Solution

I got the idea from @waltinator to search for other places where autostart things might be stored. There is another, /etc/xdg/autostart/. In it, I found a file called something like PanGPUI.desktop. When I opened that file, it pointed to another directory in /opt, which contained all sorts of stuff related to running the GlobalProtect client. Deleting both the file in /etc/xdg/autostart/ and the directory in /opt, which I did through the terminal since they required sudo privileges, solved my problem.

9
  • You should also look in ~/.config/autostart/,. These get executed at GUI login time.
    – waltinator
    Dec 2, 2023 at 0:07
  • Check your startup applications and remove the app if it is there. Dec 2, 2023 at 11:35
  • Which instructions did you follow to install GlobalProtect App for Linux? ... and did you try the recommended uninstall directions?
    – rickhg12hs
    Dec 3, 2023 at 4:50
  • @waltinator That folder is empty. Are there other, similar folders that I could check?
    – E A Watson
    Dec 3, 2023 at 17:46
  • @elmo I've checked in Plasma's settings (using the GUI) and it isn't there, is there a more thorough way to check?
    – E A Watson
    Dec 3, 2023 at 17:48

1 Answer 1

0

I got the idea from @waltinator to search for other places where autostart things might be stored. There is another, /etc/xdg/autostart/. In it, I found a file called something like PanGPUI.desktop. When I opened that file, it pointed to another directory in /opt, which contained all sorts of stuff related to running the GlobalProtect client. Deleting both the file in /etc/xdg/autostart/ and the directory in /opt, which I did through the terminal since they required sudo privileges, solved my problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .