3

I am running GNOME 3.4 (Debian 7.0) and my laptop (Gigabyte Q2532), unlike all those I've used before, doesn't change application tabs with CtrlPg Up and CtrlPg Dn. This forces me to use Alt0...9, which is not always convenient. Is there something wrong with my laptop? Is this normal? How to remedy? My layout is set to English (US).

Note that I tried this with a fresh user, and still get the same issue. I'm also using GNOME 3 fallback mode.

5
+200

GtkNotebook defaults to CtrlPageUp and CtrlPageDown for switching tabs (hardcoded in gtk/gtknotebook.c).

The problem is your keys are on the numpad, so they have different keynames/keysyms, i.e.: KP_Page_Up (instead of Page_Up) and KP_Page_Down (instead of Page_Down). Remapping the keys should fix it. I have no numpad on my XPS 15 to test but something like this should work:

xmodmap -e 'keysym KP_Prior = Prior' -e 'keysym KP_Next = Next'

You could also patch the source code, replacing all occurrences of GDK_KEY_Page_Up/GDK_KEY_Page_Down with GDK_KEY_KP_Page_Up/GDK_KEY_KP_Page_Down in gtknotebook.c


Since you're on Gnome, you can make it permanent by adding it to your start-up programs. In terminal, run gnome-session-properties, then Add:

Name: Whatever
Command: xmodmap -e 'keysym KP_Prior = Prior' -e 'keysym KP_Next = Next'
Comment: Whatever

Alternatively, create a file ~/.Xmodmap with this content:

keysym KP_Prior = Prior
keysym KP_Next = Next

test if it works with:

xmodmap ~/.Xmodmap

Load it at start-up with xmodmap /home/yourusername/.Xmodmap, via gnome-session-properties, xinitrc, xprofile. E.g. (note the full path for the file):

gnome-session-properties >> Add :

Name: Whatever
Command: xmodmap /home/tshepang/.Xmodmap
Comment: Whatever

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.