0

Problem: Mount point and folder on second nvme is not mounting on startup. One might expect mounting to occur using /etc/fstab entries, but that is not happening.

The directory does mount when manually using cli.

System Specs:

MX-Linux 23.1 with current updates. System: Kernel: 6.5.0-1mx-ahs-amd64 [6.5.3-1~mx23ahs] arch: x86_64 bits: 64 compiler: gcc v: 12.2.0 parameters: BOOT_IMAGE=/boot/vmlinuz-6.5.0-1mx-ahs-amd64 root=UUID= ro splash Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm v: 4.18.0 vt: 7 dm: LightDM v: 1.26.0 Distro: MX-23.1_ahs_x64 Libretto October 15 2023 base: Debian GNU/Linux 12 (bookworm)

Machine:

Type: Desktop System: Gigabyte product: H470M DS3H v: -CF serial: Mobo: Gigabyte model: H470M DS3H v: x.x serial: UEFI: American Megatrends v: F4 date: 08/28/2020 CPU: Info: model: Intel Core i9-10850K bits: 64 type: MT MCP arch: Comet Lake gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xF8[/CODE]

/etc/fstab contains:

"# Pluggable devices are handled by uDev, they are not in fstab

UUID=8af127bf-3a7f-476c-9f2b-9c45b017c850 / ext4 discard,noatime 1 1

UUID=4017-E145 /boot/efi vfat noatime,dmask=0002,fmask=0113 0 0

UUID=86656e34-9372-43b4-bcfc-d855da6d2925 /home ext4 discard,noatime 1 0

/swap/swap swap swap defaults 0 0"

"# /mnt/Data_PNY_2TB

#UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/Data_PNY_2TB ext4 discard,noatime 1 0"

UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/Data_PNY_2TB ext4 auto,default 0 0

Note: NVMe of interest is UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/Data_PNY_2TB Data_PNY_2TB is installed in the system but does not mount at startup.

NVMes installed in the system:

$ lsblk -f | grep nvme nvme1n1
└─nvme1n1p1 ext4 1.0 PNY_2TB_Label 4dae6d7c-f5bd-4ee9-b412-9ca648984e5d
nvme0n1
├─nvme0n1p1 vfat FAT32 EFI-SYSTEM 4017-E145 251.8M 0% /boot/efi ├─nvme0n1p2 ext4 1.0 rootMX23 8af127bf-3a7f-476c-9f2b-9c45b017c850 88.7G 14% / └─nvme0n1p3 ext4 1.0 homeMX 86656e34-9372-43b4-bcfc-d855da6d2925 1.6T 0% /home

$ sudo blkid /dev/nvme1n1p1

/dev/nvme1n1p1: LABEL="PNY_2TB_Label" UUID="4dae6d7c-f5bd-4ee9-b412-9ca648984e5d" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="PNY_2TB_Partition" PARTUUID="06928216-0fe6-4800-8e65-b6355225df8e"

NVMes mounted at startup:

$ sudo mount |grep nvme

/dev/nvme0n1p2 on / type ext4 (rw,noatime,discard)

/dev/nvme0n1p1 on /boot/efi type vfat (rw,noatime,fmask=0113,dmask=0002,allow_utime=0020,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro)

/dev/nvme0n1p3 on /home type ext4 (rw,noatime,discard)

Objective: Mount the second nvme disk at startup to be used for data storage including writing MX Snapshot isos and Timeshift storage location. It should be visible in Thunar Devices; Thunar is the MX-Linux Xfce default file manager.

Solution, recommendations and comments invited. Thanks in advance.

Additional testing:

modifying last entry in fstab to

UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt ext4 auto,default 0 0

and running sudo mount -a mount: /mnt: wrong fs type, bad option, bad superblock on /dev/nvme1n1p1, missing codepage or helper program, or other error. dmesg(1) may have more information after failed mount system call.

Which gives:

$ sudo dmesg | grep nvme1 [ 4.567014] nvme nvme1: pci function 0000:05:00.0 [ 4.572284] nvme nvme1: missing or invalid SUBNQN field. [ 4.572903] nvme nvme1: Shutdown timeout set to 10 seconds [ 4.577315] nvme nvme1: 8/0/0 default/read/poll queues [ 4.578339] nvme nvme1: Ignoring bogus Namespace Identifiers [ 4.579902] nvme1n1: p1

But manually using using cli it works:

$ sudo mount UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt mrmx@mymx:~/Desktop $ cd /mnt mrmx@mymx:/mnt $ ls Data_PNY_2TB

and $ UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/Data_PNY_2TB bash: /mnt/Data_PNY_2TB: Is a directory

sudo mount UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/Data_PNY_2TB

/mnt/Data_PNY_2TB is now mounted:

$ sudo mount |grep nvme1n1p1 /dev/nvme1n1p1 on /mnt type ext4 (rw,relatime) /dev/nvme1n1p1 on /mnt/Data_PNY_2TB type ext4 (rw,relatime)

Data_PNY_2TB does not mount at startup using fstab but does mount using cli.

============================================================

I am uncertain as to how to provide additional information obtained from using the suggestions provide in the comments so far. Here are the results so far.

Thanks for the help and -- for the link. Good read. I’ll have to remember that ... if all else fails read the kernel man pages (directions). :)

After correcting transcription/spelling/typo in /etc/fstab,

$ cat /etc/fstab | grep UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d #UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/Data_PNY_2TB ext4 discard,noatime 1 0

UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/Data_PNY_2TB ext4 defaults 0 0

#UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt/ ext4 auto,default 0 0

After using sudo chmod 666 /mnt and sudo chmod 666 /mnt/Data_PNY_2TB/, in addition to sudo chown mrmx:mrmx /mnt/Data_PNY_2TB/ in case there were user-owner issues:

The permissions listed for the folder Data_PNY_2TB are not the same, depending upon whether they are listed by /mnt or by /mnt/Data_PNY_2TB, which seems a bit odd,

even though the output listed the same folders whether using ls /mnt or ls /mnt/Data_PNY_2TB, except permissions for Data_PNY_2TB are different, as shown below:

$ sudo ls -hal /mnt

total 16K

drw-rw-rw- 4 mrmx mrmx 4.0K Dec 1 11:15 .

drwxr-xr-x 19 root root 4.0K Dec 1 10:43 ..

drw-rw-rw- 4 mrmx mrmx 4.0K Dec 1 11:15 Data_PNY_2TB

drwxr-xr-x 2 root root 4.0K Dec 1 10:19 folderT_1 and

$ sudo ls -hal /mnt/Data_PNY_2TB

total 16K

drw-rw-rw- 4 mrmx mrmx 4.0K Dec 1 11:15 .

drw-rw-rw- 4 mrmx mrmx 4.0K Dec 1 11:15 ..

drwxr-xr-x 2 mrmx mrmx 4.0K Nov 29 17:55 Data_PNY_2TB

drwxr-xr-x 2 root root 4.0K Dec 1 10:19 folderT_1

After unsuccessfully attempting to make a new folder inside Data_PNY_2TB using Thunar, and attempting to write a snapshot ISO into Data_PNY_2TB, additional investigation of /mnt/Data_PNY_2TB/ was conducted. The additional investigations are listed first, then the output of attempting to create a folder inside /mnt/Data_PNY_2TB/ and attempting to write an ISO using snapshot to /mnt/Data_PNY_2TB/ is shown.

Additional Investigations: When I attempt to make a new folder inside /mnt/Data_PNY_2TB using

$ sudo mkdir /mnt/Data_PNY_2TB/folder_T_2,

The command sudo mkdir /mnt/Data_PNY_2TB/folder_T_2 does not make a folder in the directory /Data_PNY_2TB as expected but rather puts the new folder in /mnt:

$ sudo mkdir /mnt/Data_PNY_2TB/folder_T_2

Listing both ls -hal /mnt/Data_PNY_2TB and ls -hal /mnt gives different permissions for the folder Data_PNY_2TB, much the same as the above examples.

$ sudo ls -hal /mnt/Data_PNY_2TB

total 20K

drw-rw-rw- 5 mrmx mrmx 4.0K Dec 1 11:38 .

drw-rw-rw- 5 mrmx mrmx 4.0K Dec 1 11:38 ..

drwxr-xr-x 2 mrmx mrmx 4.0K Nov 29 17:55 Data_PNY_2TB

drwxr-xr-x 2 root root 4.0K Dec 1 10:19 folderT_1

drwxr-xr-x 2 root root 4.0K Dec 1 11:38 folder_T_2

compared to

$ sudo ls -hal /mnt

total 20K

drw-rw-rw- 5 mrmx mrmx 4.0K Dec 1 11:38 .

drwxr-xr-x 19 root root 4.0K Dec 1 10:43 ..

drw-rw-rw- 5 mrmx mrmx 4.0K Dec 1 11:38 Data_PNY_2TB

drwxr-xr-x 2 root root 4.0K Dec 1 10:19 folderT_1

drwxr-xr-x 2 root root 4.0K Dec 1 11:38 folder_T_2

Though permissions are different for Data_PNY_2TB, the output for the above ls commands is otherwise the same as far as directories listed. I expected permissions for /Data_PNY_2TB to be the same regardless of which of the above two ls commands were used.

The Thunar file manager does not allow a new folder to be created in the directory /mnt/Data_PNY_2TB either.

Neither does Snapshot allow a folder to be created in /mnt/Data_PNY_2TB/ but defaults to instead /mnt/snapshot. (Since screen shots of the active windows are not allowed, a text description will have to do.)

When Snapshot is run, it is not able to create an ISO file in /mnt/snapshot.

The error message says “Could not create ISO file, please check whether you have enough space on the destination partition.”

But the nvme was newly formatted and has lots as space as is clearly demonstrated with:

$ sudo df /mnt/Data_PNY_2TB/folder_T_2

Filesystem 1K-blocks Used Available Use% Mounted on

/dev/nvme1n1p1 1921742316 28 1824050232 1% /mnt/Data_PNY_2TB

There is something going on I don’t understand well here. :)

Solutions, recommendations and comments invited.

Would an using external M.2 USB adapter bypass the problem currently experienced with the second motherboard based M.2 nvme used as a data disk for folder Data_PNY+2TB?

2 Answers 2

1

The option you are trying to use is called "defaults" not "default". That would make the correct /etc/fstab entry:

UUID=4dae6d7c-f5bd-4ee9-b412-9ca648984e5d /mnt ext4 defaults,auto 0 0

https://manpages.debian.org/testing/mount/mount.8.en.html#:~:text=selinux(8).-,defaults,-Use%20the%20default

Edit: The reason your manual mount worked is that you did not provide any options (so the typo did not happen) and everything went fine.

7
  • may be good to point out that auto is redundant when using defaults :p - never mind, it may not be since the "real" defaults could be something other than documented :p Dec 1, 2023 at 0:35
  • It also says in the documentation "[...] that the real set of all default mount options depends on the kernel and filesystem type."
    – michihupf
    Dec 1, 2023 at 7:46
  • defaults is redundant when you specify any other mount options though. It's basically a placeholder to use when you need no non-default mount options.
    – Tom Yan
    Dec 1, 2023 at 8:56
  • @TomYan do you have a source for that? Seems quite inconvenient as you'd have to provide the default options yourself then and I also can't find anything about that in mount(8) or fstab(5).
    – michihupf
    Dec 1, 2023 at 9:13
  • @michihupf Not sure what you mean. What I meant was if you (need to) have anything else in the mount options field, you don't need defaults there. defaults is just what to use when you don't need to put anything else there. (You can also use one or more default mount options as the placeholder, but that sucks for OCD.)
    – Tom Yan
    Dec 1, 2023 at 9:36
0

Replacing the nvme resolved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .