I'm trying to set single key to operate anything i want in gnome settings.

I'm using Debian-12 and Gnome 43.

Settings->Keyboard>View and Customize Shortcuts(Keyboard Shortcuts)->Custom Shortcuts->Add Shortcut->Set Shortcut

enter image description here

In Set Shortcut panel, single keys is not detected(neither model nor standard keys, i.e Super, Alt, CTRL, Shift etc. But Function keys could be detected i.e F1,F5...)

The thing I'm trying to do is to add single key and run any command by the shortcut or be able to change already available shortcuts by a single key i.e. pressing only super key should open application menu like in pressing in Windows key to open start menu.

So far, I've tried to change it by dconf editor and played around with settings;

org > gnome > desktop > input-sources > sources

org > gnome > desktop > input-sources > xkb-options

enter image description here

as in this link described but it didn't work.

Can you help. Thanks.


2 Answers 2


Just follow these steps:

  • Create your custom-keybinding (just use any shortcut keys, you are going to change it in the next step anyways)
  • Open the dconf editor
  • Go to /org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/
  • Click on your newly created keybinding named custom[::number::]
  • Go to binding and change the Custom Value

Thats it :)

P.S.: Well written question from you, I like it :)

  • Thank you very much :) I've tried but any shortcut doesn't work. I cannot open or run any command through those settings even by standard settings. Apparently, there is a problem. I'm gonna search and if i can resolve i'm gonna let you know.
    – livan3li
    Commented Nov 29, 2023 at 19:48
  • I would recommend to check if it is a shortcut problem or a command problem. Try for example to put the shortcut to b and the command to /usr/bin/gnome-terminal. I have tried it yesterday and worked on my PC :)
    – Bog
    Commented Nov 30, 2023 at 8:55
  • I couldn't find the problem. I think due to the some package I've removed before this operations so rolled back the system from backup. Now it's fixed. I can now change the shortcut. But there is another problem. I neither find the place where super key is used in the settings I've showed above gif video nor from conf editor.(I've searched and nothing appears). The behavior that I want to change is activities which shows all windows of applications that is running. But again thanks. Your answer is correct except some rare situations like this one.
    – livan3li
    Commented Dec 1, 2023 at 8:38

I've found the solution for the problem which I mentioned in the comment under Pixelbog's answer.

If you want to change any behavior(key-binding shortcut) that belongs to gnome shell and also if it doesn't exist in the Settings->Keyboard>View and Customize Shortcuts(Keyboard Shortcuts) you need to follow these steps:

  1. Find the command(key binding feature) and it's path that you want to change it's shortcut in the terminal by using gsettings list-recursively | grep SEARCH-TERM command. https://askubuntu.com/questions/169704/how-to-search-dconf-for-keys-or-values
  2. Go to the path in the dconf editor.
  3. Change the shortcut however you like.

or if you don't want to use UI you can do as following.

  1. Do above first step
  2. And set new shortcut for the behavior you want to change by following gsettings set org.gnome.shell.keybindings toggle-application-view "['Super_L']"

How to set Super/Windows key to Show All Applications menu in GNOME DE?


  1. If you want to change from multiple key bindings to only modal keys you need to do as following: from ['<Super_L>F10'] to ['Super_L']
  2. If you are trying to change a key-binding, which is belongs to an extension, you actually need to go to following path in dconf editor(since you may not find corresponding shortcut setting by following 2nd method on terminal, at least i couldn't): /org/gnome/shell/extensions/EXTENSION-NAME/.../key-binding-settings that you want to change

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .