0

I have a WH16NS40 DVD drive that I want to use on my Debian 12 virtual machine. The drive is inside a Vantec NexStar DX2 USB 3.0 external enclosure, which connects to the DVD drive via a standard SATA cable.

I had it working and was able to read and write ISOs to discs from my Debian 12 workstation, but when I plugged it into my hypervisor (Proxmox) and passed the USB device through to the VM, it does not show up as sr0 in lsblk and is not in /dev for sr0. The USB part does show up though, as shown below.

lsusb

Bus 002 Device 002: ID 152d:0578 JMicron Technology Corp. / JMicron USA Technology Corp. JMS578 SATA 6Gb/s

lshw

                 *-usb
                      description: Mass storage device
                      product: USB to ATA/ATAPI Bridge
                      vendor: JMicron
                      physical id: 1
                      bus info: usb@2:1
                      version: 4.15
                      serial: 0123456789ABCDEF
                      capabilities: usb-2.10 scsi
                      configuration: driver=usb-storage maxpower=30mA speed=480Mbit/s

dmesg output:

[    1.418561] usb 2-1: New USB device found, idVendor=152d, idProduct=0578, bcdDevice= 4.15
[    1.418564] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.418565] usb 2-1: Product: USB to ATA/ATAPI Bridge
[    1.418566] usb 2-1: Manufacturer: JMicron
[    1.418566] usb 2-1: SerialNumber: 0123456789ABCDEF
[    1.422595] usb-storage 2-1:1.0: USB Mass Storage device detected
[    1.422697] usb-storage 2-1:1.0: Quirks match for vid 152d pid 0578: 1000000
[    1.422734] scsi host3: usb-storage 2-1:1.0
[    1.422797] usbcore: registered new interface driver usb-storage
[    1.423715] usbcore: registered new interface driver uas

Even before I put a disc in the drive, it was present in my workstation as /dev/sr0. But not here. My workstation is running KDE desktop, are there packages that come with KDE that make detecting these USB enclosures more accurate?

How can I force the OS to consider this USB device a CDROM device and assign it as sr0?

Thanks in advance!

7
  • 1
    As you said yourself, The USB part, so it's not about force the OS to consider this USB device a CDROM device, but the question is, where's the SCSI part/target? This is either because the adapter cannot detect the CDROM, which could in turn because the CDROM is dead, or the machine's kernel does not have the sr-mod driver built (it could be due to some kernel/module version mismatch problem caused by kernel update and/or misconfiguration as well). And I can't completely rule out that it could be some passthrough hiccup either.
    – Tom Yan
    Commented Nov 22, 2023 at 4:44
  • I just plugged the drive into my workstation again and it works just fine. I guess this is potentially an issue with USB passthrough in Proxmox?
    – bdrun33
    Commented Nov 22, 2023 at 7:35
  • 1
    Maybe, but check zgrep CONFIG_BLK_DEV_SR /proc/config.gz in the VM first. If it =m, further check modinfo sr_mod.
    – Tom Yan
    Commented Nov 22, 2023 at 8:01
  • My kernel doesnt have a /proc/config.gz, but /lib/modules/$(uname -r)/build/.config does have the line CONFIG_BLK_DEV_SR=m. And sr_mod is a module on disk, but is not currently loaded. I tried loading it, but nothing in lsblk. I put sr_mod in /etc/modules and rebooted, but still nothing in lsblk.
    – bdrun33
    Commented Nov 22, 2023 at 17:43
  • Does it show up (in e.g. lsblk) of the proxmox host (if you do not have it passed through to a VM)?
    – Tom Yan
    Commented Nov 22, 2023 at 18:11

1 Answer 1

0

Just solved my issue, turns out I had USBGUARD running on the host. Allowing the USB enclosure on the host allowed the passthrough to operate and the VM now sees the DVD drive.

Saw Device is not authorized for usage in dmesg on the host. Then ran usbguard list-devices And the USB to SATA device was number 16 usbguard allow-device -p 16

Hopefully this will help others avoid such a simple mistake!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .